Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1. Вычислить

5-9 класс

сумму первых N
слагаемых 12+22-32+42+52-62+…(каждое
третье слагаемое берется со знаком «минус»).

Bashkatovakris 05 мая 2016 г., 23:17:31 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dinarochka2003
06 мая 2016 г., 1:12:25 (7 лет назад)

1)
var
  b, c, n: integer;

begin
  readln(n);
  c := 12;
  for b := 2 to n do
    if (b mod 2 = 0) then
      c := c + (b * 10 + 2)
    else
      c := c - (b * 10 + 2);
  writeln(c);
end.

2)
var
  max, min, n, i, t: integer;

begin
  readln(n);
  if (n = 0) then exit;
  readln(t);
  min := 65536;
  max := -65536;
  for i := 2 to n do
  begin
    readln(t);
    if ((t > 0) and (t < min)) then
      min := t;
    if ((t < 0) and (t > max)) then
      max := t;
  end;
  
  writeln(max, ' ', min);
end.

Ответить

Другие вопросы из категории

Читайте также

1.вычислите значение логического выражения при всех возможных значениях логических величин X и Y; X или (X не Y)

2.вычислите значение логического выражения при всех возможных значениях логических величин A и B; не(не A или не B) или A
3.вычислите значение логического выражения при всех возможных значениях логических величин A,B и C не(A или B и C) или A
4.вычислите значение логического выражения при всех возможных значениях логических величин A и B; B или не A и не B.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ,НУЖНО ОЧЕНЬ СРОЧНО,: (решение задач с параметром,язык PASCAL) №1)дано натуральное n, вычислить:

а) -2/1! +3/2! -...+ (-1)^n *(n+1)/n! (n после единицы это степень)

б) 1!/1+ 2!/ (1+1/2) +....+ n!/ (1+1/2+...+1/n)

№2) дано натуральное n, действительное х, вычислить:

а) x^1 / 1! + x^2 /2+...+ x^n / n!

б)(1/2 - cosx)(2/3-(cos^2)*x)).....( n/(n+1) - (cos^n)* x))



Вы находитесь на странице вопроса "1. Вычислить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.