Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

ПАСКАЛЬ АВС .МАССИВЫ.

5-9 класс

сформировать целочисленный массив из 15 элементов произвольных чисел .вывести отдельно элементы исходного массива ,превышающие его среднее арифметическое .

Jobs1962 20 июля 2013 г., 5:40:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
винала
20 июля 2013 г., 6:16:50 (10 лет назад)

uses crt;
var a:array [1..15] of integer;
    x,sum:integer;
    sr:real;
begin
     randomize;
     sum:=0;
     for x:=1 to 15 do
     begin
          a[x]:=random(15)+1;
          sum:=sum+a[x];
          writeln('a[',x,']:',a[x]);
     end;
     sr:=sum/15;
     writeln;
     for x:=1 to 15 do
         if a[x]>sr then write(a[x]:3);
end.

Ответить

Другие вопросы из категории

Объем видеопамяти равен 128 Кбайт, количество используемых цветов – 16.

Вычислите варианты разрешающей способности дисплея при условии, что
видеопамять делится на 2 страницы. с решением, пожалуйста

Определите,какой из представленных на рисунке кругов соответствует множеству:

а)"европейский город";
б)"город в Англии";
в)"столичный европейский город".



Перечислите города-объекты,являющиеся элементами представленных на рисунке множеств.

Помогите пожалуйста.Только 2

Читайте также

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Напишите программу для паскаль авс

Задачи:
1.Ввести три целых числа, найти максимальное из них
2.Ввести пять целых чисел, найти максимальное из них

Помогите составить программу решения задачи в паскаль АВС.

Даны два целых числа А и В (А меньше В). Найти сумму всех целых чисел от А до В включительно.



Вы находитесь на странице вопроса "ПАСКАЛЬ АВС .МАССИВЫ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.