Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

№1

10-11 класс

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

настююююха 18 сент. 2013 г., 3:19:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Persepaliya
18 сент. 2013 г., 3:49:18 (10 лет назад)

N1
var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;
b := b mod 2;
•​ if (b > 0) and (a > 0) then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');
end.

Ответить

Другие вопросы из категории

В алфавите племени МУМУ всего 4 буквы (А, У, М, К), один знак препинания (точка) и для разделения слов используется пробел. Подсчитали, что в популярном

романе «Мумука» содержится всего 10000 знаков, из них: букв А - 4000, букв У - 1000, букв М - 2000, букв К - 1500, точек -500, пробелов - 1000. Какое количество информации содержит книга?

помогите пожалуйста, срочно нужно
Упростить логическое выражение:

1) (X1 v X2) & (X1 v X2)
2) (X1vX1)v(X2vX2)v(X3vX3)

Верно ли, что самое длинное слово в строке содержит

больше 10 букв? Программа должна вывести одно слово: «Верно» или «Неверно»(Pascal ABC)

Читайте также



Вы находитесь на странице вопроса "№1", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.