Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Программа для определения требуемых величин на побочной диагонали двумерного массива.

5-9 класс

Размер 30
Имя D
Должна выполнять функции:
1)Найти минимальный элемент
2)Найти сумму положительных чисел
3)Минимальное четное число
4)Количество отрицательных четных чисел
5)Сумму положительных нечетных чисел

Ladka99 14 июля 2014 г., 23:36:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanyakravchenk1
15 июля 2014 г., 1:33:45 (9 лет назад)

Вот мой ответ в догонку (зря писал что ли).
Компилятор - Pascal ABC.NET

+ 0 -
Provodnik2011
15 июля 2014 г., 2:11:34 (9 лет назад)

const
  n = 30;
var
 D: array[1..n, 1..n] of integer;
  e, min, sump, min2, kol2n, sum1p: integer;
  i, j: integer;

begin
  Randomize;
  min := 1000;
  sump := 0;
  min2 := 1000;
  kol2n := 0;
  sum1p := 0;
  for i := 1 to n do
    for j := 1 to n do
    begin
      e := Random(1000) - 500;
      if min > e then min := e;
      if e > 0 then
      begin
        sump := sump + e;
        if (e mod 2) <> 0 then sum1p := sum1p + e
      end;
      if (e mod 2) = 0 then
      begin
        if min2 > e then min2 := e;
        if e < 0 then kol2n := kol2n + 1
      end;
      D[i, j] := e
    end;
  writeln('Минимальный элемент:                       ', min:6);
  writeln('Сумма положительных элементов:             ', sump:6);
  writeln('Минимальный четный элемент:                ', min2:6);
  writeln('Количество отрицательных четных элементов: ', kol2n:6);
  writeln('Сумма положительных нечетных элементов:    ', sum1p:6)
end.

Тестовое решение:

Минимальный элемент:                                        -499
Сумма положительных элементов:                   115454
Минимальный четный элемент:                            -494
Количество отрицательных четных элементов:      226
Сумма положительных нечетных элементов:     60710




+ 0 -
Bogdansemenov
15 июля 2014 г., 4:18:14 (9 лет назад)

Комментарий удален

+ 0 -
97mura97
15 июля 2014 г., 7:06:05 (9 лет назад)

рандом

+ 0 -
Sdsdad
15 июля 2014 г., 7:44:59 (9 лет назад)

Комментарий удален

+ 0 -
Cat77stewchuck
15 июля 2014 г., 9:52:36 (9 лет назад)

ты здесь?

+ 0 -
Riseman
15 июля 2014 г., 11:40:51 (9 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

В таблице Dat представлены данные о количестве голосов, поданных за10 исполнителей народных песен (Dat[1] – количество голосов, поданныхза первого

исполнителя, Dat[2] – за второго и т. д.). Определите, какоечисло будет напечатано в результате работы следующей программы. Текстпрограммы приведён на трёх языках программирования.

Cоставить блок схему для задач:

1)найти среднее арифметическое двух чисел.
2 задача)составить число семетричное данному двухзначному числу

Читайте также

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три

четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование: Количество: Цена,руб:
Красная шапочка 500 г k
Алые паруса 200 г a
Воронежские 100 г b
Чародейка 250 г m

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

Подберите окончание для предложения. Графический редактор - это ... .а)устройство для создания и редактирования рисунковб) программа для создания и

редактирования текстовых документовв) устройство для печати рисунков на бумагег) программа для создания и редактирования рисунков



Вы находитесь на странице вопроса "Программа для определения требуемых величин на побочной диагонали двумерного массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.