Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Дана последовательность целых чисел, оканчивающаяся числом 100.

5-9 класс

Определить, есть ли в последовательности число 77. Если такое число
есть, то вывести «Yes». В противном случае вывести «No». Решить данную
задачу двумя способами, используя циклы с пред и пост условиями.( в ПАСКАЛЕ)

Rin651141 27 июля 2014 г., 15:41:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КартинДеМяу
27 июля 2014 г., 17:54:59 (9 лет назад)

1)Первый способ:
program one;
var a,b:integer;
begin
b:=0;
readln(a);
while a<>100 do
begin
if a=77 then
begin
b:=b+1;
readln(a);
end
else readln(a);
end;
if b>0 then writeln('Yes')
else writeln('No');
end.
2)Второй способ: 
program one;
var a,b:integer;
begin
b:=0;
repeat
readln(a);
if a=77 then b:=b+1;
until a=100;
if b>0 then writeln('Yes')
else writeln('No');
end.




+ 0 -
Soldatenko02
27 июля 2014 г., 19:04:28 (9 лет назад)

вайл и репит ?

Ответить

Другие вопросы из категории

Программа для определения требуемых величин на побочной диагонали двумерного массива.

Размер 30
Имя D
Должна выполнять функции:
1)Найти минимальный элемент
2)Найти сумму положительных чисел
3)Минимальное четное число
4)Количество отрицательных четных чисел
5)Сумму положительных нечетных чисел

В таблице Dat представлены данные о количестве голосов, поданных за10 исполнителей народных песен (Dat[1] – количество голосов, поданныхза первого

исполнителя, Dat[2] – за второго и т. д.). Определите, какоечисло будет напечатано в результате работы следующей программы. Текстпрограммы приведён на трёх языках программирования.

Читайте также

Дана последовательность целых чисел, оканчивающаяся числом 100. Определить, есть ли в последовательности число 77. Если такое число есть, то вывести

«Yes». В противном случае вывести «No». Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.



Вы находитесь на странице вопроса "Дана последовательность целых чисел, оканчивающаяся числом 100.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.