Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите в паскале ABC .

10-11 класс

Известно время полета вылета самолета - HH часов и ММ
минут, а также продолжительность полета (НР часов и МР минут). Напечатать время
прибытия самолета в аэропорт назначения в виде: самолет прибывает в
12.35. Учесть возможность перехода часов (после 23.59 наступает 00.00).

Lizzok2003 11 апр. 2015 г., 20:56:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natasha1980god
11 апр. 2015 г., 22:56:16 (9 лет назад)

program time;
uses crt;
var
HH,MM,HP,MP,HR,MR,ost:integer;
begin
write('Vvedite vremya otvravki : ');
read(HH);
read(MM);
writeln;
write('vvedite prodolgitelnost poleta: ');
read(hp);
read(mp);
clrscr;
writeln('Otpravleniye somolyata v ',hh,':',mm);

MR:=mm+mp;
 if mr>59 then
 begin
 ost:=mr mod 60;
 MR:=ost;
 HR:=HR+(MR div 60);
 end;
 
HR:=HH+HP;
if hr>24 then hr:=hr - 24;

Writeln;
Write('Pributie samolyota v ', HR,':',MR);
writeln;

end.


данный можно сразу вводить через пробел...
например 12 10 жмем ентер и вводим другие 14 55 и ентер и все прекрасно посчитает. тут опечатка...не совсем правильно считает... подожди исправлю

Ответить

Другие вопросы из категории

Для передачи по каналу связи сообщения, состоящего только из символов А, Б, В и Г, используется посимвольное кодирование: А – 00, Б – 11, В – 010, Г –

011. Через канал связи передаётся сообщение: ВБГАГВ.Закодируйте сообщение данным кодом. Полученное двоичное число переведите в шестнадцатеричный вид.

Как пройти 7 уровень час кода

Читайте также

Как заменить программму в турбо паскале чтоб она решалась в паскале ABC? program kRUGI;

uses crt;
var gd,gm,c,i,r,x,y,n:integer;
begin
clrscr;
randomize;
writeln('введите колличество окружностей->');
readln(n);
gd:=0;
for i:=1 to n do begin
r:=random(80);x:=random(600);y:=random(400);
c:=random(15);setcolor(c);
circle(x,y,r);
setfillstyler(1,c);floodfill(x,y,c);
end;
readkey;
closegraph;
end.

Решите в Паскаль ABC

Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас
имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в
N рублей так, чтобы она состояла из минимального
количества монет.

решить в паскаль abc

оператор выбора case.
В библиотеке в книжном шкафу 10 полок, на каждой из них разная литература: 1 – математика; 2 – физика; 3 – химия; 4 – программирование; 5 – русский язык; 6 – литература для чтения; 7-10 – пустые полки. Напишите программу, которая выводит сообщение, о том какие книги находятся на данной полке. В случае если введено число больше 10, выводится сообщение «Полки с таким номером нет».

дано трехзначное число. найдите сумму его цифр.

решите кодом Паскаля abc.
заранее спасибо

решите программу в паскаль abc

прошу, очень надо!!!



Вы находитесь на странице вопроса "Решите в паскале ABC .", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.