Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Работа по Паскалю.вычислить среднее арифметическое элементов массива состоящего из 30 целых случайных чисел меньших 100 которые

10-11 класс

делятся на 3 и не деляться на 7

Cat1498 25 июля 2015 г., 11:50:04 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Taliya0606
25 июля 2015 г., 12:46:52 (8 лет назад)

program proga1;
var
a:array[1..30] of integer;
i,count,summ:integer;
begin
randomize;
for i:=1 to 30 do
   a[i]:=random(100);
for i:=1 to 30 do
  if (a[i] mod 3 = 0) and (a[i] mod 7 <>0)then
  begin 
  inc(count);
  inc(summ,a[i]); 
 end;
if count<>0 then
write(summ/count)
else
write('ничего нет');
end.

+ 0 -
Валерая
25 июля 2015 г., 14:48:08 (8 лет назад)

что-то мало баллов(

Ответить

Другие вопросы из категории

В ячейке B3 записана формула =2*A$1. Какой вид приобретёт формула,

после того как ячейку B3 скопируют в ячейку C4?
Примечание: знак $ используется для обозначения абсолютной адресации.
1) =2*A$1 2) =2*A$2 3) =2*B$1 4) =2*B$2

не запускается флешка почему
Написать программы в Паскале

• Дан массив из N вещественных чисел. Поменять местами последний и минимальный элементы массива.
• Дан массив из N целых чисел. Найти номер первого элемента, который равен количеству элементов, кратных 3.

Читайте также

В одномерном массиве, состоящем из n целых элементов, вычислить:


1) Сумму модулей элементов массива, больших числа X

2)Сумму модулей элементов массива, меньших числа X

Ребята, девчата, тут такое затруднение. Нужна программа в паскале, только в паскале.

Условие:
Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3*8) . Программа по двумерным массивам.

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.

Помогите, Пожалуйста, с программой Паскаль. Рассмотрим целочисленный массив А[1..N] при N <= 100.

Написать программу, которая вычисляет среднее арифметическое элементов с четными индексами и среднее арифметическое с нечетными индексами.
Ввод: Число N и элементы массива вводятся из Файла.
Вывод: В файл должны быть введены 2 вычисленных значения



Вы находитесь на странице вопроса "Работа по Паскалю.вычислить среднее арифметическое элементов массива состоящего из 30 целых случайных чисел меньших 100 которые", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.