Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Помогите решить задание пожалуйста. На С++.

5-9 класс

Составить программу вычисления суммы S=1!+2!+3!+....n!
! - факториал.

Stepanuk2011 08 апр. 2016 г., 10:06:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Larisovka72
08 апр. 2016 г., 12:39:15 (7 лет назад)

#include <iostream>

int main()
{
    int n, s, m, mas[32000];
    
    freopen ("input.txt", "r", stdin);
    freopen ("output.txt", "w", stdout);
    
    scanf ("%d", &n);
    mas[0] = m = 1;
    
    for (int i = n; i > 1; i--)
    {
        s = 0;
        for (int j = 0; j < m; j++)
        {
            s = s + mas[j]*i;
            mas[j] = s%10;
            s = s/10;
        }

        while (s > 0)
            {
                mas[m] = s%10;
                s = s/10;
                m++;
            }
        int j = 0;
        while (mas[j] == 9)
        {
            mas[j] = 0;
            j++;
        }
        mas[j] = mas[j]+1;
        if (j > m) m = j;
    } 
    for (int i = m-1; i >= 0; i--) printf ("%d", mas[i]);
return 0;
}

+ 0 -
Artjusha
08 апр. 2016 г., 13:30:26 (7 лет назад)

#include <iostream>
#include <stdlib.h>

unsigned long fact(int number) {
    unsigned long i = 1;
    for (;number > 1; number--)
        i *= number;
    return i;
}

int main(int argc, char** argv) {
    if (argc != 2)
        return 1;
    unsigned long s = 0;
    for (int i = 1; i <= atoi(argv[1]); i++)
        s += fact(i);
    std::cout << s << std::endl;
    return 0;
}


Ответить

Читайте также

Помогите с заданием пожалуйста

Решите задание 3.13

Помогите решить задания. СРОЧНЯК!

1. Задан массив целых чисел. Вычислить суммы нечетных и отрицательных элементов.
2.Задана матрица целых чисел. Вычислить сумму элементов расположенных на главной и побочной диагоналях.
И это на с++

ИНФОРМАТИКА 2 класс помогите с заданием ) 2 класс !!!!!!

помогите с заданием ) 2 класс !!!!!! ПОЖАЛУЙСТА
обведите синим два слова с одинаковым мешком букв:
1) мандарин
2)командир
3)светофор
4)помидор
5)пудель
:)спаниель
7)апельсин
8)кардамон
9)мойдодыр
и пожалуйста обьясните как это делать плиииз :*

помогите решить задание по информатике

задание на картинке



Вы находитесь на странице вопроса "Помогите решить задание пожалуйста. На С++.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.