Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила

5-9 класс

большее число то пользователь нажимает < если программа предложила меньшее число то пользователь нажимает > а если угадала то =
Тема циклы

Anton29000 27 апр. 2016 г., 15:06:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kikkk
27 апр. 2016 г., 17:34:20 (7 лет назад)

var min,max,n:integer;
c:string;
Begin
    min:=1;
    max:=1000;
    repeat
        n:=(max+min) div 2;
        writeln(n);
        read(c);
        case c of
            ">": min:=n+1;
            "<": max:=n-1;
        end
    until (c="=");
End.

Ответить

Другие вопросы из категории

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


Очень надо!! пожалуйста)Составить программу на языке Pascal, которая позволяет ввести с клавиатуры целое трехзначное число, проверяет, симметрично ли оно,

и печатает сообщение на экране. (Трёхзначное число симметрично, если крайние цифры числа одинаковые)

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"



Вы находитесь на странице вопроса "Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.