Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Даны два натуральных числа. Определить, значение большего из них и во сколько раз. Если числа равны, то вывести "EQUALS".

5-9 класс

пятёрачка 02 нояб. 2013 г., 23:48:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sebosha
03 нояб. 2013 г., 2:39:01 (10 лет назад)

#include <iostream>

int main()
{
    int a,b;
    std::cin >> a >> b;
    if (a==b)
        std::cout <<"EQUALS\n";
    else
    {
        int max=(a>b) ? a:b;
        float v=(a>b) ? float(a)/b:float(b)/a;
        std::cout <<"max: " <<max <<" v " <<v  <<" raz\n";
    }
    return 0;
}

Ответить

Другие вопросы из категории

один из первых отечественных персональных компьютеров БК-0010 имел оперативную память объемом 16 кбайт. сколько страниц текста можно было бы разместить в

памяти этого компьютера,если на странице разрешается 40 строк по 60 символов в каждой строке,а для хранения одного символа требуется 8 битов

было отсканировано цветное изображение размером 10х15 см с разрешением 100dpi и количество цветов 65536.фаил был сохранён в формате bmp без сжатия.из

предложенных вариантов выберите наиболее подходящий размер файла.напоминаю что 1 дюйм=2.54см.
а)450.56 мбаит
б)4400 кбайт
в)0.44 мбайт
г)1151 кбаит

Читайте также

Напишите программу, которая в последовательность натуральных чисел определит значение наибольшего из всех нечетных введеный чисел. Программа

получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входят в последовательность) .

Количество чисел не привышает 1000. Введеные числа не привышают 30000.

Программа должна вывести одно число - наибольшее из всех нечеиных введеных чисел.

Пример работы программы:

Входные данные Выходные данные

15 17

20

17

0

1)Даны два целых числа A и B (A < B). Найти сумму квадратов всех целых чисел

от A до B включительно.
2)Даны натуральные числа от A до B(A<B). Найти произведение тех из них, которые делятся на 3 и не делятся на 4.
3)Ангелина узнав, что Боря занимается спортом, решила не отставать. Она каждый день делала от 3 до 5 упражнений на икры (вводится во время выполнения программы) и 5 упражнений на пресс. Сколько упражнений она сделала за 5, 10 и 13 дней. (количество упражнений на икры на каждый день вводится отдельно)


Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

Ребят, помогите решить!

Дано два натуральных числа N и M.
Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно.
Формат входных данных:
Входной файл INPUT.TXT содержит два натуральных числа N (10<=N<=10^100) и M (10<=M<=10^100), разделенных одним пробелом.
Формат выходных данных:
Выходной файл OUTPUT.TXT должен содержать найденной наименьшее число.
Пример
INPUT.txt. OUTPUT.txt
423 42 22344



Вы находитесь на странице вопроса "Даны два натуральных числа. Определить, значение большего из них и во сколько раз. Если числа равны, то вывести "EQUALS".", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.