Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводится целое шестизначное число. Необходимо определить, является ли оно "счастливым". ("Счастливыми" называются те числа, у которых сумма

5-9 класс

перых трёх цифр равна сумме вторых трёх цифр).

Sddfg 20 февр. 2014 г., 10:48:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sabinka0697
20 февр. 2014 г., 12:56:00 (10 лет назад)

var
x:string;
a1,a2,a3,b1,b2,b3,cd:integer;
begin
readln(x);
if length(x) = 6 then
begin
val(copy(x,1,1),a1,cd);
val(copy(x,2,1),a2,cd);
val(copy(x,3,1),a3,cd);
val(copy(x,4,1),b1,cd);
val(copy(x,5,1),b2,cd);
val(copy(x,6,1),b3,cd);

if a1+a2+a3 = b1+b2+b3 then
writeln('Lucky')
else
writeln('not Lucky');
end;
read;
end.

Ответить

Другие вопросы из категории

Доброго всем вечера/дня!Пожалуйста,помогите с Информатикой

записать программу в ПАСКАЛЬ(!)
Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет.
И если не сложно,то с подробными объяснениями!!!




Всем заранее спасибо!!!)

Б)собственная (внутренняя) память человека

В) внешняя память записные книжки справочники энциклопедии и т.д.
Г)любой материальный обьект используемый фиксации и хранения на нём информации

Читайте также

С клавиатуры вводится натуральное число n выясните является ли оно квадратом какого то натурального числа если является то выведите это число если нет то

вывести -1 например 4 является квадратом 2 а 17 не является квадратом никакого числа.

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

I В паскале с помощью генератора случайных чисел получить двузначное число и

1) найти и вывести сумму его цифр
2) сформировать число, в котором поменяются разряды (допустим будет число 13, нужно сделать, что бы было 31 и т.п.)
II В паскале с помощью генератора случайных чисел получить трехзначное число и определить, является ли оно полимером (например 121 - является, 123 - нет)



Вы находитесь на странице вопроса "С клавиатуры вводится целое шестизначное число. Необходимо определить, является ли оно "счастливым". ("Счастливыми" называются те числа, у которых сумма", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.