Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите пожалуйста!!!!

10-11 класс

Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. К каждому элементу массива прибавить 1, вывести получившийся массив. Подсказка: 1)random(10)-10 2) положительные: >0 неположительные: <=0 отрицательные: <0 неотрицательные:>=0

Anastka 12 июля 2014 г., 1:24:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
RiNjVfh
12 июля 2014 г., 3:31:16 (9 лет назад)

program gt;
var a:array[1..10]of integer;
i,min,l,s,k:integer;
begin
randomize;
s:=0;
k:=0;
for i:=1 to 10 do
begin
a[i]:=random(20)-10;
write(a[i],' ');
s:=s+a[i];
if(a[i]<0)then k:=k+1;
end;
min:=a[1];l:=1;
for i:=2 to 10 do
if(a[i]<=min)then begin
min:=a[i];
l:=i;
end;
writeln;
writeln('сумма элементов массива=',s);
writeln('кол-во отрицательных элементов массива=',k);
writeln('минимальный элемент массива=',min,' его индекс=',l);
for i:=1 to 10 do
begin
a[i]:=a[i]+1;
write(a[i],' ');
end;
end.


+ 0 -
Lenadedi1988
12 июля 2014 г., 5:40:06 (9 лет назад)

вопросы?

+ 0 -
Nedbajloan11
12 июля 2014 г., 8:11:45 (9 лет назад)

понятно?

Ответить

Другие вопросы из категории

В бейсике

Составьте программу, которая:
1) Из слова «ИНСТРУМЕНТЫ» составляет слова «ТРУС», «СТРУНЫ»;
2) Из слов «ШИШКА», «ФЛАГ», «ТРОС» получает слово «ШРИФТ».

1. Определите

значение переменной S после выполнения операторов:

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.