Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

На двух первых днях рождениях у пяточка Винни-Пух съел всего 100г пищи.Составить програму ,которая определяет,сколько килограммов пищи съест Винни-Пух

10-11 класс

на 15 дне рождении,если на каждом следующим дне рождении он съедает столько сколько на предыдущих.обрати внимание что граммы надо образовать в кг.

Kolotov211999 12 апр. 2014 г., 4:40:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
стимсд
12 апр. 2014 г., 6:13:24 (9 лет назад)

Написал программу на Паскале. с расширением pas.

+ 0 -
MakTavishh
12 апр. 2014 г., 6:43:47 (9 лет назад)

var
a:array[2..14] of integer;
i:byte;
begin
a[2]:=100;
for i := 3 to 14 do
a[i]:=a[i-1]*2;
writeln(a[14] div 1000,',',a[14] mod 1000,'кг');
readln;
end.

Ответить

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

с клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и

последняя буквы слова

в)выводт на экран первый,второй и последний символы

г)определяет,чётно или нечётно количество символов в нём

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.



Вы находитесь на странице вопроса "На двух первых днях рождениях у пяточка Винни-Пух съел всего 100г пищи.Составить програму ,которая определяет,сколько килограммов пищи съест Винни-Пух", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.