Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Задано натуральное четырехзначное число. Получить из его цифр все возможные двузначные числа

10-11 класс

Pascal, решите пжл

Irina020 12 авг. 2014 г., 8:12:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ДенниПризрак
12 авг. 2014 г., 8:49:50 (9 лет назад)

var a,b,k,l,m,n:integer;
begin
readln(a);
b:=a;
n:=a mod 10;
k:=a div 1000;
l:=(a mod 1000) div 100;
m:=(a mod 100) div 10;
writeln(k+l,' ',k+m,' ',k+l,' ',l+m,' ',l+n,' ',m+n);
end.


+ 0 -
Alinkadior
12 авг. 2014 г., 10:30:04 (9 лет назад)

каким способом требуется получить двузначные числа из цифр? сложение, умножение, вычитание, деление?

+ 0 -
YaroslavZ
12 авг. 2014 г., 11:02:30 (9 лет назад)

Сложением

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!!

Составить программу на Паскале. Ввести 10 целых случайных чисел (в интервале от -10 до 10). Вывести исходный массив. Найти и вывести: 1) минимальный элемент и его индекс; 2) сумму всех элементов массива; 3) количество отрицательных элементов. К каждому элементу массива прибавить 1, вывести получившийся массив. Подсказка: 1)random(10)-10 2) положительные: >0 неположительные: <=0 отрицательные: <0 неотрицательные:>=0

В бейсике

Составьте программу, которая:
1) Из слова «ИНСТРУМЕНТЫ» составляет слова «ТРУС», «СТРУНЫ»;
2) Из слов «ШИШКА», «ФЛАГ», «ТРОС» получает слово «ШРИФТ».

1. Определите

значение переменной S после выполнения операторов:

Читайте также

Игрок А объявляет двузначное число от 01 до 99. Игрок В меняет местами его цифры и прибавляет полученное число к сумме его цифр. Полученный результат он

объявляет игроку А. Игрок А проделывает с этим числом ту же процедуру, и так они продолжают поступать поочередно, объявляя числа. От суммы чисел берется остаток от деления на 100, поэтому объявляются лишь двузначные числа. Какие числа может объявить игрок А на начальном шаге, чтобы игрок В в некоторый момент объявил число 00.

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

1)Сколько бит информации несёт каждое двузначное число(отвлекаясь от его конкретного числового значения)?

2)Какое количество вопросов достаточно задать вашему собеседнику,чтобы точно определить число и месяц его рождения?
3)Происходит выбор одной карты из колоды 32 карты. Какое количество информации мы получаем в зрительном сообщении о выборе определённой карты?

Запись

некоторого натурального числа X в шестнадцатеричной системе счисления имеет
ровно три значащих разряда. Это число увеличили в два раза, и оказалось, что
запись получившегося числа Y в шестнадцатеричной системе также имеет ровно три
значащих разряда, причем сумма цифр шестнадцатеричной записи исходного числа X
равна сумме цифр шестнадцатеричной записи полученного числа Y. Сколько
существует таких чисел X, которые удовлетворяют указанным условиям и при этом
содержат хотя бы одну цифру 2 в своей шестнадцатеричной записи? В ответе
укажите целое число.
Нужно составить программу, которая автоматически переберет все числа от 100 до FFF

Помоги срочно надо!!! С написанным на доске числом производят следующее действие. Каждую его цифру возводят в квадрат, все результаты суммируют и

результат выписывают на доску вместо исходного числа. Так продолжается сколько угодно раз. Опишите алгоритм, определяющий, можно ли таким образом получить из начального натурального числа N заданное натуральное число M? Обоснуйте конечность разработанного алгоритма.



Вы находитесь на странице вопроса "Задано натуральное четырехзначное число. Получить из его цифр все возможные двузначные числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.