Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти сумму чётных цифр числа) Помогите пожалуйста) Решить в паскале. Буду очень благодарна)

5-9 класс

Valerzv 01 мая 2015 г., 0:47:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
наташуля79
01 мая 2015 г., 3:22:46 (9 лет назад)

var
s:integer;
a,n:longint;
begin
write ('A =');readln(a);

if (a div 10 = 0) and (odd(a)=false) then s:=a else begin
n:=a; 
while n div 10 <> 0 do begin
n:=a; 
if odd(a mod 10)=false then s:=s+a mod 10;
a:=a div 10;
end;

end;
writeln (s);
readln;
end.

Ответить

Другие вопросы из категории

Граждане информатики, прошу помощи. Pascal ABC.

Что не так в коде? Надо найти НОК трёх чисел через алгоритм Евклида.
Тест: числа 4,6,18, ответ 36.

Код:

Program No4;
var a,b,c:integer;

{----------АЛГОРИТМ ЕВКЛИДА----------}
function evc (a,b:integer):integer;
var m,m1,m2,z:integer;
begin
z:=0;
//определение большего числа
if a=b then evc:=a else
begin
if a>b then

begin
///m1 - большее число из двух, m2 - меньшее.
m1:=a;
m2:=b;
end

else

begin
m1:=b;
m2:=a;
end;
//определение большего числа - готово
repeat
m:=m1 mod m2; ///Большее число делим на меньшее;
if m=0 then z:=m2 ///Если делится - то НОД есть меньшее число;
else begin ///Иначе меняем большее на меньшее,а меньшее - на остаток от деления (по Евклиду).
m1:=m2;
m2:=m;
end
until z<>0;///Повторяем, пока НОД не появится.

evc:=z;
end;
end;
{---------/АЛГОРИТМ ЕВКЛИДА----------}


{----------АЛГОРИТМ НОК----------}
function znam (a, b, c:integer):integer;
var Nabc,Nab:integer;
begin
Nab:=evc (a,b); ///НОД (а.b) - это результат алгоритма Евклида для чисел А и B:
Nabc:=evc (c, Nab); ///НОД (С,Nab) - это результат алгоритма Евклида для чисел С и Nab:
znam:=a*b*c div Nabc; ///НОК = ПРОИЗВ. ЧИСЕЛ / НОД
end;
{----------АЛГОРИТМ НОК----------}

begin
readln (a,b,c);
writeln (znam (a,b,c));
end.

Заранее спасибо.

срочно решите Пожалуйста
как угнать автозапчасти

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Введите целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1234
Сумма цифр числа 1234 равна 10.

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1 2 3 4
Сумма цифр числа 1 2 3 4 равна 10

Помогите пожалуйста решить задачи!!!

Задание 1. Составить программу для вычисления по формуле:

Y = √|2x² - 7x| + 12
Задание 2.
Составить программу для вычисления значения функции:
F(x) = \left \{ {{0, If x <=2} \atop {1/(x^{2}+ 6), if x>1 }} \right. {{

Задание 3. Дано натуральное N. Вычислить: S=2*4*6*...*2N.
Задание 4. Дан массив А(20), заполненный датчиком случайных числе. Найти среднее арифметическое всех элементов массива.
Задание 5. дана матрица А(10,10), заполненная датчиком случайных чисел. Найти сумму значений всех элементов данной матрицы.



Вы находитесь на странице вопроса "Найти сумму чётных цифр числа) Помогите пожалуйста) Решить в паскале. Буду очень благодарна)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.