Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

найдите последнюю цифру в записи числа х=(57∧8) 2014∧ 16 в 16-ричной системе счисления

5-9 класс

Dabu 11 мая 2016 г., 21:00:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89159885686никита
11 мая 2016 г., 22:53:40 (7 лет назад)

57 в восьмеричной системе - это в нашей 10-ричной 47.
2014 в шестнадцатеричной - это в нашей 8212.
Составить алгоритм по нахождению последней цифры при возведении а в степень b не сложно:
var
i,a,b,p:word; {диапазон целых чисел 0..65535}
Begin
readln(a,b);p:=a mod 10;       {первая степень числа а}
for i:=2 to b do {если степень больше 1, то в цикле начинаем домножать, пока № витка цикла не дойдет до b }
begin
p:=p*a;  {домножаем результат на последнюю цифру числа а}
p:=p mod 10; {отделяем последнюю цифру результата}
end;
writeln(p);     {по окончании цикла в р находится результат задачи}
end.
В результате вводимых данных (47 и 8212) получаем 1. Думаю, что и в 16-ричной будет тоже 1.

Ответить

Читайте также

Найдите последнюю цифру в записи числа

x= 57^{2014}
57 - восьмеричная система счисления.
2014 - шестнадцатеричная системы счисления.

Перевести число 36910 в двоичную, восьмеричную и шестнадцатеричные системы счисления

Перевести число 11100012 в восьмеричную, десятичную и шестнадцатеричные системы счисления

Решите пожалуйста !!!!!!

Как записываеться десятичное число 27 в 16-рично системе счисления ?

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

В числе ,записанном в римской системе счисления ,поменяли местами вторую и третью,четвёртую и пятую от начала цифры,а затем перевели результат в

десятичную систему счисления.Получилось число 2162.Определите исходное число,переведите его в десятичную систему счисления и запишите результат.Напомним ,что для записи чисел в римской системе счисления используется набор из семи цифр(I,V,X,L,C,D,M)
а)1924 б)1492 в)1294 г)1942



Вы находитесь на странице вопроса "найдите последнюю цифру в записи числа х=(57∧8) 2014∧ 16 в 16-ричной системе счисления", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.