Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив натуральных чисел A[N]. Найти сумму элементов, кратных заданному натуральному К. помогите плииииз на яз..c++

10-11 класс

Katypoimanova 20 февр. 2017 г., 6:17:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tumyp4uk
20 февр. 2017 г., 7:48:44 (7 лет назад)

#include <iostream>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    int k=0,s=0,n;
    cout<<"Введите размер массива: ";
    cin>>n;
    int a[n];
    for (int i=0; i<n; i++) cin>>a[i];
    cout<<"\nВведите K: ";
    cin>>k;
    for (int i=0; i<n; i++) if (a[i]%k==0) s+=a[i];
    cout<<"\nСумма чисел кратных "<<k<<" = "<<s<<endl;
    system("PAUSE");
}

+ 0 -
Roman7171
20 февр. 2017 г., 8:21:45 (7 лет назад)


#include <iostream>
#include<time.h>
using namespace std;
const int N = 10;
void main()
{
srand(time(NULL));
int a[N];
int krat(0);int sum(0);
for (int i = 0; i < N;i++) a[i]=rand()%30-5;
cin>>krat;
for (int i = 0; i < N; i++) if (a[i]%krat==0) sum+=a[i];
cout<<"\nSUMA KRATNYH = "<<sum<<endl;
system("pause");
}

Ответить

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Дан массив натуральных чисел A[N]. Найти сумму элементов, кратных заданному натуральному К. помогите плииииз на яз..c++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.