Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста!!!

5-9 класс

Дан целочисленный массив A размера N (<=15). Переписать в новый целочисленный массив B все элементы с нечетными порядковыми номерами (1,3...) и вывести размер полученного массива B и его содержимое.Условный оператор не использовать

Kamik271001 15 янв. 2014 г., 13:09:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nfstya2201
15 янв. 2014 г., 14:53:18 (10 лет назад)

Easy
Как-то так)
const
n=15;
var
z:integer;
i:integer;
a:array[1..n] of integer;
b:array[1..(n div 2)+1]of integer;
begin
randomize;
for i:=1 to n do
 begin
a[i]:=random(99)+1;
write(a[i],' ');
end;
writeln;
i:=-1;
z:=1;
while i<n do
begin
i:=i+2;
b[z]:=a[i];
z:=z+1;
end;
for i:=1 to (n div 2)+1 do write(b[i],' ');

end.

Ответить

Другие вопросы из категории

Сладкоежка Пончик решил испечь на свой день рождения 3 торта: яблочный, ореховый и шоколадный. Для приготовления одного яблочного торта требуется 200 г

сливочного масла, 200 г муки, 2 яйца, 300 г сахара и 8 яблок. Для приготовления одного орехового торта надо 200 г орехов, 400 г муки, 300 г сахара, 300 г масла и 3 яйца. На один шоколадный торт тратится 3 шоколадки, 2 яйца, 300 г муки, 200 г масла и 100 г сахара. Масло в Цветочном городе стоит 100 мо¬нет за кг, сахар — 20 монет за кг, яйца — 20 монет за десяток, мука — 30 монет за кг, орехи — 100 монет за кг, яблоки — 2 монеты за штуку, шоколадки — 10 монет за штуку. Сколько будет стоить каждый торт? Сколько продуктов каждого вида Пончик должен купить и сколько это будет стоить? Сколько всего денег он должен взять с собой в магазин, от¬правляясь за продуктами? Пожалуйста нарисуйте таблицу как это должно выглядеть или в экселе сразу.Очень нужно!!!

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите пожалуйста!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.