Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Срочно помогите!!

10-11 класс

Дан массив из 10ти целых чисел , введенных с клавиатуры. Найти и заменить все нулевые элементы на минимальный элемент массива.

Jyliakuropjatnik 11 сент. 2014 г., 12:08:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Limbakov1997
11 сент. 2014 г., 13:22:12 (9 лет назад)

var
  i,min:integer;
  m:array[1..10] of integer;
begin
for i:=1 to 10 do
  begin
  readln(m[i]);
  if i=1 then min:=m[i];
  if m[i]<min then min:=m[i];
  end;
for i:=1 to 10 do
  begin
  if m[i]=0 then m[i]:=min;
  write(m[i],' ');
  end;
end.

+ 0 -
Kamgil
11 сент. 2014 г., 15:33:08 (9 лет назад)

На паскале не проверял, надеюсь будет работать

Ответить

Другие вопросы из категории

Паскаль.

Нужно написать программу, которая высчитывает среднею температуру, максимальную и минимальную температуру за месяц.
Вот, пытался написать сам, не получается:
program PoGoda;
uses crt;
var
x, n, t : integer;
max, min, imax, imin : integer;
const z=5;
begin
for x := 0 to z do;
x :=1;
while (x < z+1)do
begin {Создаем массив}
while (x > z) do
writeln;
write ('Какая температура была в ');
write ( x);
write (' день? ');
readln (t);
inc (x);
end;
max:= t[x];
for x:=0 to z do
if max begin
max:=t;
imax:=x
end
else
if min>t then
begin
min:=t;
imin:=x
end;
writeln;
writeln('Максимальное значение ',max);
writeln('В какой день месяца было максимальное значение ',imax);
writeln('Минимальное значение ',min);
writeln('В какой день месяца было минимальное значение ',imin);


readkey;
end.


Читайте также

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

ребят очень срочно помогите ;(
СРОЧНО:( ПОМОГИТЕ(((((

Дан двумерный массив. Все его элементы разделить на первый элемент и вывести на экран полученный массив.



Вы находитесь на странице вопроса "Срочно помогите!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.