Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

ПОМОГИТЕ ПОЖАЛУЙСТА!! №1

5-9 класс

Даны числа a, b, c, составляющие стороны треугольника и числа d,
f, составляющие стороны прямоугольника. Написать программу,
определяющую, площадь какой фигуры больше.
№2
Даны объёмы и массы двух тел из разных материалов. Написать
программу, определяющую плотность какого материала больше.
№4

Пользовать вводит с клавиатуры два числа a и b. Написать
программу, определяющую:
1). является ли число a делителем числа b;
2). является ли число b делителем числа

Bukka2004211 16 июля 2014 г., 11:08:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Белника
16 июля 2014 г., 12:18:53 (9 лет назад)

1)

var
    a, b, c, d, f : Integer;
   S : Real;
begin

 

   Writeln( 'Введите стороны треугольника:' );
   Write( 'a = ' ); Readlln( a );
   Write( 'b = ' ); Readlln( b );
   Write( 'c = ' ); Readlln( c );


   Writeln( 'Введите стороны прямоугольника:' );
   Write( 'd = ' ); Readlln( d );
   Write( 'f = ' ); Readlln( f );

   S := (a + b + c) / 2;
   S := sqr( S * (S-a) * (S-b) * (S-c) );

   if (d * f) = S then
      Writeln( 'S прямоугольника = S треугольника.' )
   else if (d * f) > S then
      Writeln( 'S прямоугольника больше.' )
   else
      Writeln( 'S треугольника больше.' );

   Readln;
end.

 

2)

var
   m, V, m1, V1 : Integer;
begin

   Writeln( 'Введите объем и массу первого тела:' );
   Write( 'm = ' ); Readlln( m );
   Write( 'V = ' ); Readlln( V );


   Writeln( 'Введите объем и массу второго тела:' );
   Write( 'm = ' ); Readlln( m1 );
   Write( 'V = ' ); Readlln( V1 );

   if (m / V) = (m1 / V1) then
      Writeln( 'Плотности равны.' )
   else if (m / V) > (m / V) then
      Writeln( 'Плотность первого тела больше.' )
   else
      Writeln( 'Плотность второго тела больше.' );

   Readln;
end.

 

3)

var
    a, b : Integer;
begin

 

   Writeln( 'Введите числа:' );
   Write( 'a = ' ); Readlln( a );
   Write( 'b = ' ); Readlln( b );


   if a mod b = 0 then
      Write( 'Число a является делителем числа b.' );

   if b mod a = 0 then
      Write( 'Число b является делителем числа a.' );

   Readln;
end.

Ответить

Другие вопросы из категории

Постройте математические модели для приведённых ниже задач. Какой вы можете сделать вывод на основании полученных моделей ?

u>
а) первая бригада может выполнить задание за А дней, а вторая - за Б дней.За сколько дней обе бригады выполнят задание , работая вместе?
б) Два велосипедиста одновременно одновременно направились навстречу к друг другу из двух сел. Первый мог бы проехать расстояние между селами за А минут, второй за Б минут. Через сколько минут они встретятся?
Решите пожалуйста, очень надо!

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "ПОМОГИТЕ ПОЖАЛУЙСТА!! №1", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.