Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Пусть элементами круга

10-11 класс

являются радиус (первый элемент), диаметр (второй элемент) и длина окружности
(третий элемент). Составить программу, которая по номеру элемента запрашивала
бы его соответствующее значение и вычисляла бы площадь круга.
Решение на паскале!

Krasotka555 14 февр. 2015 г., 7:50:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kinderkarhaul
14 февр. 2015 г., 9:10:34 (9 лет назад)

var
  a: real;
  k: byte;

begin
  writeln('1 - l okp.');
  writeln('2 - r okp.');
  writeln('3 - d okp.');
  readln(k);
  readln(a);
  write('S = ');
  case k of
    1: writeln(sqr(a) / (4 * Pi):0:2);
    2: writeln(Pi * sqr(a):0:2);
    3: writeln(Pi * sqr(a / 2):0:2);
    else writeln('?');
  end;
end.

Ответить

Другие вопросы из категории

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0

найти максимальный по значению элемент матрицы x (n,m) (n<=10,m<=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое

положительных элементов матрицы. полученную матрицу x и среднее арифмитическое распечатать



Вы находитесь на странице вопроса "Пусть элементами круга", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.