Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Підрахувати суму та добуток чисел менших за 100 і кратниз 3

10-11 класс

Grafio 26 мая 2015 г., 13:55:22 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Julika2015
26 мая 2015 г., 16:33:18 (8 лет назад)

var
  x,sum: integer;
  prod: double;
begin
  prod:= 1;
  sum:= 0;
  x:= 1;
  while x<100 do begin
    if x mod 3 = 0 then begin
      sum:= sum+x;
      prod:= prod*x
    end;
    inc(x)
  end;
  writeln('Сумма=',sum);
  writeln('Произведение=',prod)
end.

Ответить

Другие вопросы из категории

Основные понятия логики высказываний. Помогите пожалуйста!!!!!!!!! Определите, является ли логическая формула (┌ P→Q&┌Q)→P тождественно истинной.

Запишите формулой алгебры высказываний предложение " Если записать числа заканчивается цифрой 0 или 5, то это число делится на 5 "

Пусть элементами круга

являются радиус (первый элемент), диаметр (второй элемент) и длина окружности
(третий элемент). Составить программу, которая по номеру элемента запрашивала
бы его соответствующее значение и вычисляла бы площадь круга.
Решение на паскале!

Читайте также

вычислите произведение всех целых чисел, расположенных за минимальным значением.

нужна программа для open office
как объяснила мне препод: вводишь произвольное количество чисел(допустим 6 чисел), с помощью формулы "min" вычислить минимальное... и нужно перемножить все числа расположенные после этого минимального числа)
например: 2 3 0 6 7 8 min=0
и нужно по какой-то функции перемножить числа 6 7 8
и если 0 поставить в другое место, числа после 0 все также перемножались)

Нужно решения задач по Delphi...(хотя бы одной)

1,Описати статичний масив.
Масив зчитується з текстового файлу.
Визначити:
Мінімальне значення масиву, його індекси

Задана матриця (n×m). Визначити номер рядка, середньоарифметичне елементів якої менше за середньоарифметичне попереднього рядка


2.Текстовий файл F1 має містити не менше 10 рядків.
Скопіювати з файлу F1 в файл F2 всі рядки, які не містять слова, яке починається за задану літеру. Визначте найкоротше слово у файлі F2.


помогите решить Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6. Пример работы программы: Входные данные Выходные данные 3 12 25 6 18 20.2

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 3. Программа получает на вход количество

чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3.Количество чисел не превышает 100. Введённые числа не превышают 300.Программа должна вывести одно число – сумму чисел, оканчивающихся на 3.
Паскаль



Вы находитесь на странице вопроса "Підрахувати суму та добуток чисел менших за 100 і кратниз 3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.