Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

помогите написать блок-схем алогритм " игры автомат" например 777 вычислить выиграть да и 436 проиграть нет. и "мишень"любой число

10-11 класс

Msgorbuhova 14 июня 2015 г., 7:01:49 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Erfefs
14 июня 2015 г., 7:58:46 (8 лет назад)

См. вложения.

________________________________

 

Код на Паскале:

 

var a:integer;
begin
a:=random(11)+1;
writeln(a);
if (a mod 10=a div 100) and
(a mod 10= a mod 100 div 10) then
write('Выиграл')
else write('Проиграл');
end.

 

var a:integer;
begin
a:=random(10)+1;
write('Своим выстрелом Вы набрали ',a,' очков.');
end.

Ответить

Другие вопросы из категории

Напишите программу которая вводит значение четырех переменных A, B, C, D типа integer и выводит их сумму. Ввод пары значений A и B произвести на одной

строке, C и D на другой. Результат вывести на отдельную строку и курсор оставить на этой же строк

Помогите пожалуйста;) Нужно к завтра срочно!

От чего зависит реальная скорость подключения к интернету с помощью ADSL-cоединения? С помощью GPRS-соединения? Соединения с помощью локальной сети?

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.



Вы находитесь на странице вопроса "помогите написать блок-схем алогритм " игры автомат" например 777 вычислить выиграть да и 436 проиграть нет. и "мишень"любой число", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.