Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

ПОМОГИТЕ! ТОЛЬКО НУЖНО РЕШИТЬ НЕ ЧЕРЕЗ if, A ЧЕРЕЗ CASE1. Пользователь вводит неотрицательное однозначное число A. Написать программу:

10-11 класс

вычисляющую в случае ввода 1 - площадь круга с радиусом A,
вычисляющую в случае ввода 2 - площадь квадрата со стороной A,
вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,выдающую сообщение «нужно ввести число 1, 2, 3» в остальных случаях.

Klown 18 июня 2013 г., 21:01:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Knara80
18 июня 2013 г., 22:49:12 (10 лет назад)

var a:integer;
s:real;
begin
readln(a);
case a of
1: begin s:=pi*a*a; writeln(s); end;
2: begin s:=a*a; writeln(s); end;
3: begin s:=a*a*sqrt(3)/4; writeln(s); end;
else writeln('нужно ввести число 1, 2, 3');
end;
end.

Ответить

Другие вопросы из категории

Описать

процедуру RectDiag(a, b, d), вычисляющую диагональ
прямоугольника со сторонами a, b (a, b — входные, d
— выходной параметр вещественного типа).

Помогите, пожалуйста, срочно

Нужно написать программу в паскале
Найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.

Здраствуйте, пожалуйста, помогите очень прошу поЗдраствуйте, пожалуйста, помогите по информатике составить програму по примеру:

Programe...
var....:real
begin
write('....='):
readln(....):
формула и дальше
Задача.
Троим толстунам дали на десерт кремовые пирожные. Масса одного пирожные составляла х кг, а масса Толстяков в соответствии х1 кг, 2 кг, х3 кг. Первый Толстяк съел n пирожных. Каждый следующий Толстяк съедал в два раза больше предыдущего, но при этом все они не могли съесть больше, чем половина их собственной массы. Сколько пирожных съели Толстяка?

помогите с решением 1)Модем передаёт информацию со скоростью 29 к бит/с Надо предать 3 документа Обьём

документов

1)380000 байт

2)5листов по 100 символов (16бит код)

3)0.75мбайт

2)Определите информационный объем растрового изображения размером

1024х768 пикселей и состоящее из 64 цветов

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Задача в паскале.

Ввести натуральное число N. Проверить, расположены ли его цифры в порядке неубывания.
Решить НЕ ЧЕРЕЗ МАССИВ. (циклами)

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.



Вы находитесь на странице вопроса "ПОМОГИТЕ! ТОЛЬКО НУЖНО РЕШИТЬ НЕ ЧЕРЕЗ if, A ЧЕРЕЗ CASE1. Пользователь вводит неотрицательное однозначное число A. Написать программу:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.