Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале

10-11 класс

Натусикк 21 мая 2014 г., 6:22:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dariad5904
21 мая 2014 г., 7:50:54 (9 лет назад)

var
   n:longint;
   i,s,p,y:integer;
   t:string;
   x:real;
begin
write('Введите число: ');
readln(n);
p:=1;
t:=IntToStr(n);
for i:=1 to length(t) do
  begin
  y:=StrToInt(t[i]);
  if y>1 then
    begin
    s:=s+1;
    p:=p*y
    end;
  end;
x:=exp(ln(p)/s);
writeln('Среднее геом. цифр больших единицы: ',x)
end.

Ответить

Другие вопросы из категории

Парольная защита при входе в систему необходима для:

а)защиты компьютера от вирусов
б)предотвращения входа в систему постороннего пользователя
в)идентификации пользователя
2Укажите что из перечисленным относится к вредоносным программам:
а)трояны
б)сетевые черви
в)утилиты
Помогите выбрать правильные ответы

1. Задать двумерный массив (10х10) по формуле, так чтобы значения элементов совпадали с номерами столбцов в квадрате.

2. Задать двумерный массив (4х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы.
3. Задать двумерный массив (7х7) случайными значениями от 12 до 18 включительно. В каждом столбце матрицы найти количество элементов, значения которых меньше 14.
4. Задать двумерный массив (3х3) с клавиатуры, поменять значения элементов 1 столбца со вторым.
5. Найти минимальный элемент матрицы (5х5), заданной случайными значениями от 1 до 5 включительно, лежащие ниже главной диагонали.

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

5. Дано трехзначное число. Кратна ли сумма его цифр семи?

8. Дано три натуральных числа x, y, z. Вычислить количество чисел меньших 50.



Вы находитесь на странице вопроса "Дано: n-натуральное число (longint). Вычислить среднее геометрическое цифр больших единицы. Составить программу в Паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.