Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

10-11 класс

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

незнайка098 14 авг. 2014 г., 7:58:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
тыыыыы
14 авг. 2014 г., 10:17:17 (9 лет назад)

1.

var a:longint;

begin

  read(A);

  if (a mod 10)=(a div 10) then writeln('цифры одинаковы');

  if (a mod 10)>(a div 10) then writeln('вторая цифра больше');

  if (a div 10)>(a mod 10) then writeln('первая цифра больше');

end.

 

2.

var a,b,c:longint;

begin

  read(A);

  b:=a mod 10;

  c:=a div 10;

  b:=b*b*b;

  c:=c*c*c;

  d:=4*(b+c);

  if sqr(A)=d then writeln('квадрат этого числа равен учетверённой сумме кубов его цифр') else writeln(' квадрат этого числа не равен учетверённой сумме кубов его цифр');

+ 0 -
Samella Bludes
18 апр. 2017 г., 18:01:16 (7 лет назад)

А можно так. Var a :integer; Readln(a); If (a mod 10)=(a div 10) then Writeln ('равны'); Else Writeln('1 цифра больше'); End. If (a mod 10)>(a div 10) then Writeln ('2 цифра больше ');

Ответить

Другие вопросы из категории

Чему равен 1 Кбайт?Выберете один ответ:а)1000 байт

б)102байт в)2 в 10 степени байт г)1000 бит

Помогите срочно информ
1. Информационное сообщение объемом 1,5 Кбайта содержит 3072 символа. Сколько символов содержит алфавит, при помощи которого было записано это

сообщение?

2. Сообщение занимает 2 страницы и содержит 1116 Кбайты информации. На каждой странице записано 256 символов.

Какова мощность используемого алфавита?

3. Сколько килобайтов составляет сообщение, содержащее 12288 битов?

Читайте также

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игро

к может добавить в кучу два камня или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 17 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 25. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 25 или больше камней.
В начальный момент в куче было S камней, 1 ≤ S ≤ 24.
1. При каких S: 1а) Петя выигрывает первым ходом; 1б) Ваня выигрывает первым ходом?
2. Назовите три значения S, при которых Петя может выиграть своим вторым ходом?
3. При каком S Ваня выигрывает своим первым или вторым ходом?

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )



Вы находитесь на странице вопроса "1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.