Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

2. Калькулятор (100 баллов) 2 секунды и 64 Мб памяти В старинном калькуляторе работают только две клавиши — A и

10-11 класс

B. При нажатии клавиши A калькулятор увеличивает число в два раза, а при нажатии клавиши B к числу прибавляется 1. На экране записано число 1.

Вам нужно вычислить число, которое получится на экране калькулятора после выполнения заданной последовательности операций.

Формат входного файла input.txt

В единственной строке записана последовательность символов A и B без пробелов. Длина строки не менее одного и не более 50 символов.

Формат выходного файла output.txt

В единственной строке запишите целое число, которое получится после выполнения заданной последовательности операций.

Примеры input.txt

Примеры output.txt

AB

3

BA

4

ViKuXa 24 мая 2015 г., 12:44:17 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ygfhgdgx
24 мая 2015 г., 14:27:26 (8 лет назад)

var
i,x: integer;
A,B: text;
s: string;
begin
x:=1;
assign(A,'input.txt');
reset(A);
read(A,s);
close(A);
for i:= 1 to length(s) do
 begin
 if s[i] = 'A' then x:=x*2;
 if s[i] = 'B' then x:=x+1
 end;
assign(B,'output.txt');
rewrite(B);
write(B,x);
close(B); 
end.   

+ 0 -
Ola253914
24 мая 2015 г., 16:30:12 (8 лет назад)

C# без работы с файлами. Если задача c informatics.mccme.ru должно пройти.


string cmd = Console.ReadLine();     
int ans = 1; 
for (int i = 0; i < cmd.Length; i++) {
    if (cmd[i] == 'A')
        ans *= 2;
    else if (cmd[i] == 'B')
        ans++;
}
Console.WriteLine(ans);

Ответить

Другие вопросы из категории

X:=2

for k:=2 to x+2 do
write(k+k);

Помогитес олимпиадой.
решите пожалуйста в паскале abc . Телефонные разговоры с тремя населенными пунктами стоят с1, с2, с3 коп/мин. Длительность разговоров t1, t2, t3

мин. соответственно. Какую сумму насчитает компьютер к оплате за каждый разговор в отдельности и за все вместе?

Читайте также

Дан целочисленный массив из 30 элементов, которые могут принимать значения от 0 до 100 – баллы учащихся за итоговый тест по информатике. Напишите програ

мму, которая подсчитывает средний балл класса и выводит на экран номера учеников, набравших баллов больше среднего.

дан целочисленный массив из 30 элементов.Элементы массива могут принимать целые значения от 0 до 100-баллы учащихся за итоговый тест по

информатике.Опишите на русском языке или на одном из языков програмирования алгоритм, который позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе.
const N=30;
var a: array [1..N] of integer;
i, j: integer;
s: real;
begin
for i:=1 to N do readln(a[i]);
...
end.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Исполнитель КАЛЬКУЛЯТОР имеет только две команды, которым присвоены номера:

Умножь на 2

Прибавь 1

Выполняя команду номер 1, КАЛЬКУЛЯТОР умножает число на экране на 2, а выполняя
команду номер 2, прибавляет к числу на экране 1. Напишите программу, содержащую не
более 5 команд, которая из числа 6 получает число 33. Укажите лишь номера команд.

Например, программа 12122 -это программа:
Умножь на 2

Прибавь 1

Умножь на 2
Прибавь 1
Прибавь 1

которая преобразует число 5 в число 24.

ДАЮ 100 БАЛЛОВ, ТОЛЬКО ПОМОГИТЕ!

Дана вещественная матрица А, размерностью n*m. Найти в каждой строке матрицы максимальный элемент.



Вы находитесь на странице вопроса "2. Калькулятор (100 баллов) 2 секунды и 64 Мб памяти В старинном калькуляторе работают только две клавиши — A и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.