Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

А) найдите среднюю температуру за неделю (температура была: -5, - 3, -7, -6, -2, - 4, -3) Сколько дней было выше средней? Ниже средней? составить массив.

5-9 класс

67jikigffffgh 28 апр. 2013 г., 20:02:18 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Warzone97
28 апр. 2013 г., 21:13:37 (11 лет назад)

Program Frank;
const n=7;
Type mas=array[1..n] of integer;
var a:mas;i,sym,k,k1:integer;sredn:real;
begin
k:=0;
k1:=0;
a[1]:=-5;
a[2]:=-3;
a[3]:=-7;
a[4]:=-6;
a[5]:=-2;
a[6]:=-4;
a[7]:=-3;
sym:=0;
for i:=1 to n do begin
sym:=sym+a[i];
end;
sredn:=sym/n;
for i:=1 to n do begin
if a[i]>sredn then k:=k+1
else if a[i]<sredn then k1:=k1+1;
end;
writeln('Кол-во дней,когда температура была выше средней ',k);
writeln('Кол-во дней,когда температура была ниже средней ',k1);
end.

 

Ответить

Другие вопросы из категории

СРОЧНО ПОМОГИТЕ!!!! нужно
Опишите массив:

1) из целых чисел, нумерация элементов начинается с 0
2) из 12 целых чисел, нумерация элементов начинается с1
--------------
Составьте программу, которая:
1)формирует массив, содержащий 15 случайных целых чисел, принадлежащих промежутку [0; 8], и преобразует элементы массива по следующему правилу: к чётному числу прибавляется 1, а нечетное умножает на 2.
ОЧЕНЬ БУДУ БЛАГОДАРЕН

Читайте также

Помогите пожалуйста:))))!!!!!!!!


В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах(Dat[1]-данные за понедельник, Dat[2]-за вторник и тд).Определите, что будет напечатано в результате выполнения следующего алгоритма,записанного в четырёх языках.

Написать программы:1. Даны данные температуры (отриц. и полож.) за 10 дней. найти сколько дней температура была больше 0.2. Дана скорость чтения 10

пятиклассников (двухзнач.)Найти среднюю скорость чтения в 5 классе.

Решение задач с использованием массивов / Pascal (Паскаль)

Помогите, пожалуйста, решить задачу!

Определить количество дней в первой декаде месяца, когда температура была выше средней.
Исходные данные: T - массив температуры
Промежуточные данные: i - порядковый номер
SUM - суммированная температура за 10 дней
SRT - средняя температура за 10 дней
Результирующие данные: K - количество дней с температурой выше средней
SUM:=SUM+T[i]
SRT:=SUM/10
K:=K+1, если выполняется SRT<T[i]
_______________________________
Program KTD
var T:array [1..10] of real;
SUM, SRT:real;
i,K:byte;



Вы находитесь на странице вопроса "А) найдите среднюю температуру за неделю (температура была: -5, - 3, -7, -6, -2, - 4, -3) Сколько дней было выше средней? Ниже средней? составить массив.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.