Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

1) Дано трехзначное число. Определить, является ли сумма его цифр двузначным числом. 2) Дано трехзначное число. Определить какая из его цифр больше. Первая

10-11 класс

или последняя. Помогите пожалуйста,срочно надо

Nikitosnik777 10 июня 2016 г., 20:43:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akbgaliullin
10 июня 2016 г., 23:30:28 (7 лет назад)

************* 1 ***************

var
n, s: integer;

begin
  Write('Введите трехзначное число: ');
  Readln(n);
  s := (n div 100) + ((n mod 100) div 10) + (n mod 10);
  if (s in [10..99]) then Writeln('Сумма цифр двухзначная (', s, ')')
  else Writeln('Сумма цифр не двухзначная (', s, ')')
end.

Тестовое решение:

Введите трехзначное число: 269
Сумма цифр двухзначная (17)

Введите трехзначное число: 125
Сумма цифр не двухзначная (8)

************** 2 ****************

var
  n, d1, d3: integer;

begin
  Write('Введите трехзначное число: ');
  Readln(n);
  d1 := (n div 100);
  d3 := (n mod 10);
  if d1 > d3 then Writeln('Первая цифра больше третьей')
  else if d1 = d3 then Writeln('Первая цифра равна третьей')
  else Writeln('Первая цифра меньше третьей')
end.

Тестовое решение:

Введите трехзначное число: 739
Первая цифра меньше третьей



Ответить

Другие вопросы из категории

Помогите пожалуйста написать программу на C++.

Условие такого: Вычислить сумму ряда, 1-1/2+1/3-1/4...1/n.
По введенному n нужно посчитать сумму.

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)

Помогите написать программу на C++

Дано трехзначное число N. Проверить, будет ли сумма его цифр четным числом.
Я новичок в этом, так-что желательно с пояснениями.
( В интернете есть решение данной задачи, но там очень всё запутанно для начинающего, а если нам это задали, уверенна есть вариант намного проще)



Вы находитесь на странице вопроса "1) Дано трехзначное число. Определить, является ли сумма его цифр двузначным числом. 2) Дано трехзначное число. Определить какая из его цифр больше. Первая", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.