Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Здравствуйте!

5-9 класс

Информатика 9 класс.
задание.
Составьте программу, которая заполняет массив А[1..10] СЛУЧАЙНЫМИ ЦЕЛЫМИ числами в диапазоне от 1 до 10 и находит количество элементов, КОТОРЫЕ БОЛЬШЕ СВОЕГО СОСЕДА СПРАВА.

пример вывода:
Исходный массив:
10 2 4 1 3 5 7 8 2 7
Количество элементов, которые больше своего соседа справа=3
БУДУ ОЧЕНЬ БЛАГОДАРНА

Batovrin 05 мая 2014 г., 14:35:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NataxaKot
05 мая 2014 г., 16:40:54 (10 лет назад)

const   N=10;
var   a:array [1..N] of integer;   
      k,i:integer;
begin 
randomize; 
for i:=1 to N do  
    begin 
    a[i]:=random(10)+1; 
    write (a[i], ' '); 
end; 
for i:=1 to N-1 do  
   if a[i]>a[i+1] then k:=k+1;  
writeln('k= ', k);
end.

Ответить

Другие вопросы из категории

найдите пожалуйста ошибку(система паскаль) задача: даны два числа. вывести больше

е из них.

program zadacha6;

var a,b: real;

begin

readln(a,b);

if a>b then writeln ( ' a bolshe ' ) else writeln ( ' a menshee ' );

end.

Пожалуйсто подскажите как через кумир решить такую задачу:

Даны натуральные числа x и y вычеслить их произведение используя только операцыю сложения

Читайте также

Здравствуйте

Скажите пожалуйста
сколько битов в слове ? Конкретно в слове память? Сколько битов в одной букве или другом символе - например в цифре или в дефису ?
Спасибо
Дмитрий Титов

Здравствуйте! У меня есть просьба) Я учусь в техникуме и нам нужно сделать лабораторные работы. Может уже кто то такие делал, скиньте пожалуйста) Например

вот работа #13 Задание 1. Создайте папку с названием Лабораторная работа №13_ваша фамилия. Задание 2. Создайте три рисунка согласно вашему варианту в редакторе Paint и вставьте их в отчет. Задание 2. Создайте схему полусумматора двоичных чисел в редакторе Paint и вставьте ее в отчет.

Здравствуйте:)

Я не знаю как пользоваться программой GIMP
Нам задали нарисовать движущегося паучка, а я не знаю как это сделать
Не могли бы вы помочь по инструкции как это все сделать??

Здравствуйте. Помоги те решить задачу. К реке одновременно подошли три купца и три разбойника.Всем необходимо было переправится на противоположный

берег.У берега стояла лодка,которая могла вместить только двух человек.Купцы боязливо поглядывали на разбойников,так как знали,что во время переправы всякое случится.Если во время переправы на берегу число разбойников и купцов бкдет одинаковым то разбойники не тронут купцов,а если разбойников превысит число купцов хотя бы на одного человека,то разбойники убьют купцов.Сколько рейсов они сделают что бы переправится благополучно?За рейс следует считать движение лодки в одном направление.



Вы находитесь на странице вопроса "Здравствуйте!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.