Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите пожалуйста :(((

10-11 класс

Даны шесть монет, из которых одна фальшивая. Фальшивая монета отличается от настоящей монеты весом, причем она либо немного тяжелее, либо немного легче. Имея рычажные весы, определить ложную монету не более чем за три взвешивания.
Это в паскале надо)
Пожалуйста!!!!))))

ВЕБ 11 мая 2015 г., 22:24:14 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ureva1984
12 мая 2015 г., 0:40:42 (8 лет назад)

var
    a, real_coin: array[1..6] of integer;
    forged_coin, i: integer;

begin
    for i := 1 to 6 do
        a[i] := 10;
    forged_coin := random(6);
    a[forged_coin] := random(4) + 8;  
    writeln(forged_coin);
    
    for i := 1 to 6 do
        write(a[i], ' ');
    writeln;
    
    forged_coin := 0;
    if a[1] + a[2] = a[3] + a[4] then begin
        real_coin[1] := a[1];
        real_coin[2] := a[2];
        if real_coin[1] = a[5] then
            forged_coin := 6
        else forged_coin := 5;
    end
    else begin
        real_coin[1] := a[5];
        real_coin[2] := a[6];
        if a[1] + a[2] = real_coin[1] + real_coin[2] then begin
            real_coin[3] := a[1];
            real_coin[4] := a[2];
            if real_coin[1] = a[3] then
                forged_coin := 4
            else forged_coin := 3;
        end
        
        else begin
            real_coin[3] := a[3];
            real_coin[4] := a[4];
            if real_coin[1] = a[1] then
                forged_coin := 2
            else forged_coin := 1;
        end;
    end;
    
    writeln(forged_coin);
end.

Ответить

Другие вопросы из категории

Система команд исполнителя Ластик имеет вид:

(Умножение на 2),(Стереть последнюю цифру)
A) числа 7 из числа 361:
Б) числа 14 из числа 457:

Вычислить X и Y и записать ответ

2X Гбайт = 1536 Мбайт = 3Y Кбайт

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "Помогите пожалуйста :(((", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.