Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

дано целое число N. вычислить 1/1!+1/2!+1/3!+...+1/N!

10-11 класс

Leilalaila 25 февр. 2014 г., 0:35:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лиза0123
25 февр. 2014 г., 1:57:02 (10 лет назад)

На Паскале:

 

program MyProgram;
var n,i,fact: integer; sum: real;
begin
sum:=0;
fact:=1;
writeln('Введите число N.');
readln(n);
for i:=1 to n do
begin
fact:=fact*i;
sum:=sum+1/fact;
end;
writeln('Сумма 1/1!+1/2!+1/3!+...+1/N = ',sum);
end.

Ответить

Другие вопросы из категории

1. Производилась двухканальная(стерео) звукозапись с частотой дискретизации 32кГц и 24-битным разрешением. В рез-те был получен файл размером 60Мбайт, с

жатие данных не производилось. Какая из приведенных ниже величин близка к времени, в течение которого проводилась запись?

1)2мин

2)5мин

3)10мин

4)15мин

2. При регистрации в комп. системе каждому пользователю выдается пароль, состоящий из 15 символов и содержащий только символы К.О.М.П.Ь.Ю.Т.Е.Р. Каждый такой пароль в комп. программе записывается минимально возможным и одинаковым целым кол-вом байт(при этом спользуют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным кол-вом бит).

Определите объем пмяти, отводимый этой программой для записи 25 паролей.

1)150 байт

2)200байт

3)225 байт

4)250 байт

Если можно с решением пожалуйста

Помогите с паскалем! Написать программу. Составить блок схему.

Вставить заданное число в массив целых чисел перед последним четным элементом.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ



Вы находитесь на странице вопроса "дано целое число N. вычислить 1/1!+1/2!+1/3!+...+1/N!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.