Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В среде программирования FreePascal составить программу для нахождения суммы последовательности чисел произвольного диапазона. Проверить работу

5-9 класс

программы для чисел от 5 до 12

BubbleGum777 16 июля 2014 г., 5:23:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Махамбет
16 июля 2014 г., 8:06:40 (9 лет назад)

var i,d,a,b: integer;
begin
cls;
writeln('введите кол-во чисел');
readln(a,b);
d:=1;
for i:=a to b do d:=d+1;
writeln('cумма=',d);
end.

забивай числа 5 и 12 их сумма будет равняться 9

Ставь лучшее решение мне их 2 осталось

Ответить

Другие вопросы из категории

Определите, что будет напечатано в результате выполнения следующего алгоритма var k,m,i: integer; mas:array[1..10] of integer; begin

mas[1]:=12;

mas[2]:=43;

mas[3]:=48;

mas[4]:=56;

mas[5]:=76;

mas[6]:=73;

mas[7]:=36;

mas[8]:=96;

mas[9]:=69;

mas[10]:=25;

k:=0;

m1:=mas[1] div 10 - mas[1] mod 10;

for i:=2 to 10 do begin

m2:=mas[i] div 10 - mas[i] mod 10;

if m1 > m2 then begin

m1:=m2; k:=i;

end;

end;

write(k);

end.

укажите пары обьектов,о которых можно сказать ,что они находятся в отношении "обьект-модель":

А)клавиатура-микрофон
Б)река-Днепр
В)болт-чертеж болта
Г)мелодия-нотная запись мелодии
Д)весна-лето

Читайте также

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три

четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование: Количество: Цена,руб:
Красная шапочка 500 г k
Алые паруса 200 г a
Воронежские 100 г b
Чародейка 250 г m



Вы находитесь на странице вопроса "В среде программирования FreePascal составить программу для нахождения суммы последовательности чисел произвольного диапазона. Проверить работу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.