Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

в массиве Y состоящем из 12 целых чисел определить среднее арифметическое тех из них которые являются четными

5-9 класс

Vasha789 26 сент. 2015 г., 3:14:14 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Усадьба
26 сент. 2015 г., 4:09:06 (8 лет назад)

var y: array[1..12] of integer;
i,k:integer; s:real;
begin
for i:=1 to 12 do
read (y[i]);
for i:=1 to 12 do
if y[i] mod 2=0 then
begin
s:=s+y[i];
k:=k+1;
end;
s:=s/k;
write (s:5:1);
end.


Ответить

Читайте также

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1.Вставьте пропущенные слова в описании массива А, элементами которого являются целые числа. А: _________________[1..100] of ______________.

2. Опишите массив для хранения зарплаты за каждый месяц. Зарплату считать целым числом.

3.Опишите: a)Переменную В для массива, состоящую из 8 символов. b)Переменную MAS для массива, состоящего из 100 вещественных чисел. c)Переменную DAY для массива, состоящего из 30 целых чисел, причем номер первого элемента массива должен быть равен 5

.4. Пусть А : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям: a. Третий элемент массива сделать равным 5. b. Вывести на экран 7-й элемент массива. c. Ввести значение 1-го элемента массива. d. Вычислить сумму 1,2 и 3-го элементов массива.

5. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вычислить сумму всех элементов массива (используйте цикл).

6. Пусть C : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вывести на экран все элементы массива.

7. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Поменять местами первый и последний элементы массива.

8. Пусть В : array [1..20] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Заполнить массив случайными числами из интервала [-24;37].

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "в массиве Y состоящем из 12 целых чисел определить среднее арифметическое тех из них которые являются четными", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.