Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Пожалйста помогите решить!!Составить программу определяющую, является ли число x простым.

5-9 класс

Bulykodasha05 01 окт. 2015 г., 15:37:48 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shmatkov1979
01 окт. 2015 г., 17:40:42 (8 лет назад)

var x,i:integer;

a:boolean;

begin

readln(x);

for i:=2 to x-1 do if (x div i=x/i) then begin a:=true; break; end;

if a=true then writeln('Ne prostoe') else writeln('Prostoe');

end.

Ответить

Читайте также

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

Помогите, пожалуйста, решить самостоятельную:1.Составьте блок-схему и программу вычисления значения функции

(картинка дана ниже)

2.Составьте программу, определяющую, является ли данное число делителем числа 3.

3.Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее - произведением этих чисел.

Заранее спасибо.



Вы находитесь на странице вопроса "Пожалйста помогите решить!!Составить программу определяющую, является ли число x простым.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.