Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решение есть.нужно его объяснить.Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди

10-11 класс

элементов, имеющих четные значения, и максимального среди элементов имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов.Cоnst N = 30; Var a: array [1..N] of integer; MaxEv, MaxOdd, I: integer; begin for i=1 to N readln(a); MaxEv :=0; MaxOdd :=0; For I :=1 to N do if (a div 2)*2 = a then begin if a >= MaxEv then MaxEv :=a; end else if a >= MaxOdd then MaxOdd :=a; Writeln (MaxEv - MaxOdd); end.

Funny81 08 мая 2013 г., 12:50:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Serqaz123
08 мая 2013 г., 15:44:51 (10 лет назад)

Const

  N = 30;

Var

  a: array [1..N] of integer;

  MaxEv, MaxOdd, I: integer;

begin

  for i := 1 to N do

  begin

    write('a[', i , '] = ');

    readln(a[i]);

  end;

  MaxEv := 0;

  MaxOdd := 0;

  For I := 1 to N do { перебираем все элементы массива}

    if a[i] mod 2 = 0 then { проверяем делится ли текущий элемент на 2 без остатка}

    begin

      if a[i] > MaxEv then {если да, то проверяем больше ли найденного до этого наибольшего четного}

        MaxEv := a[i]; {присваиваем новое наибольшее четное значение}

     end

     else

       if a[i] > MaxOdd then {если нет, то проверяем больше ли найденного до этого наибольшего нечетного}

         MaxOdd := a[i]; {присваиваем новое наибольшее нечетное значение}

  Writeln ('MaxEv - MaxOdd = ', MaxEv, ' - ', MaxOdd, ' = ', MaxEv - MaxOdd);

end.

 

 

Ответить

Читайте также

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

СРОЧНО!!! Дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не превосходящие 10000. Опишите на русском

языке или на одном из языков программирования алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве. если таких чисел нет, нужно вывести сообщение «Таких чисел нет».

объяните решение пожалуйста программу не обязательно писать



Вы находитесь на странице вопроса "Решение есть.нужно его объяснить.Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.