Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составьте программу определяющую могут ли три числа a ,b,c является длинами сторон треугольника

5-9 класс

Ирина200000 28 янв. 2017 г., 20:01:01 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Trick000
28 янв. 2017 г., 22:28:09 (7 лет назад)

var
  a,b,c:real;
 
begin
  Write('Введите через пробел длины трех сторон: ');
  Readln(a,b,c);
  if (a+b>c) and (a+c>b) and (b+c>a) then
    Writeln('Можно составить треугольник')
  else
    Writeln('Нельзя составить треугольник')
end.

Тестовое решение:
Введите через пробел длины трех сторон: 2 6 9
Нельзя составить треугольник

Введите через пробел длины трех сторон: 3 4 5
Можно составить треугольник



Ответить

Другие вопросы из категории

Составьте алгоритм, по которому на

компьютере будет происходить следующее: в переменную S вводится возраст Саши, в
переменную М вводится возраст Маши. В качестве результата на экран выводится
фраза "Саша старше Маши" или "Маша старше Саши"
(предполагаем, что кто-нибудь из них обязательно старше). КУМИР

Алина, Валя, Галя и Диана заняли первые четыре места в олимпиаде по информатике. На вопрос: "Кто занял первое место?", - девчата ответили по-разному

Алина сказала, что Валя
Валя, что это Диана
Галя сказала, что не она
а Диана, что Валя, как всегда, шутит
Правду сказала только одна девочка. Кто занял первое место?

Помогите пожалуйста решить 2 задачи!

1.Сколько файлов размером 100 байт можно разместить на диске объемом 1.2 МБ и на диске 1.4МБ?
2. В результате повреждения односторонней дискеты 10% секторов оказалось дефектными, что составило 36864 байтов. Какой объем имеет дискета?

Читайте также

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

Помогите пожалуйста. Очень прошу) Заранее благодарна)

Дана программа:
Program p1;
var a:integer.
begin
write('Введите целое число:');
readln(a);
if(a>=100) and (a<1000)then write(' Да')
else write(' Нет');
End.
1.Запишите, что будет выведено на экране в результате выполнения данной в п.1 программы. при=-2, при а=123.
2. Внести данную программу изменения таким образом, чтобы программа определяла, удовлетворяет ли данное вещественное число а неравенству -14,5 < a <_ 18,
3. Даны целые числа a и b. Составьте программу, определяющую, есть ли среди них хотя бы одно, не равное нулю.
4. Ввести три целых числа. Если ни одно из чисел не является чётным, то вывестина экран их произведение.
Тема с Packal ABC.

ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции

деления (Div и Mod)
2.Составьте программу делящую переменную А=100 на 3. Деление прекратить когда остаток А будет меньше 3. Подсчитать количество вариантов деления и вынести значение на экран.



Вы находитесь на странице вопроса "составьте программу определяющую могут ли три числа a ,b,c является длинами сторон треугольника", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.