Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

перевод из двоичной в десятичную систему счисления

5-9 класс

101010
110111
перевод из восмеричной в десятичную систему счисления

703

101

перевод из десятичной в двоичную систему счисления

535

111

Fr0st1k 21 сент. 2014 г., 23:34:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Piester
22 сент. 2014 г., 1:13:54 (9 лет назад)

Вроде так
101010=42
110111=55
703=451
101=65
535=1000010111
111=11101111

+ 0 -
Иван120
22 сент. 2014 г., 1:51:20 (9 лет назад)

101010110111 = 211*1 + 210*0 + 29*1 + 28*0 + 27*1 + 26*0 + 25*1 + 24*1 + 23*0 + 22*1 + 21*1 + 20*1 = 2048 + 0 + 512 + 0 + 128 + 0 + 32 + 16 + 0 + 4 + 2 + 1 = 2743

Ответить

Другие вопросы из категории

В библиотеке

имеются 200 тысяч книг по 100 страниц и по 3 тысячи знаков на странице в
среднем. Какое количество информации хранится в библиотеке?

Ответ запишите в
байтах, Кбайтах, Мбайтах.

ЛЮДИ ПОМОГИТЕ ПОЖАЛУЙСТА!!!! Это тема :простые и составные условия,команда ветвление(паскаль)

составьте программу ,определяющую, является ли целое положительное число трехзначным

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

Читайте также

Переведите: 1. число 25 из десятичной системы в двоичную. 2. число 58 из десятичной системы в двоичную. 3. число 11010110 из двоичной в десятичную систему

. 4. число 11010000 из двоичной в десятичную . 5. 400мб > 2кб > байт > бит ПО ВОЗМОЖНОСТИ БЫСТРЕЕ

СРОЧНО

было 11 яблок . после того как их разрезали пополам, стало 110 половинок.возможно ли это? обоснуйте ответ.

переведите числа из десятичной системы счисления в двоичную: 100, 37, 168, 241.


переведите из двоичной в десятичную систему счисления: 1110 , 11000, 1110, 10100, 11110,10010.



Вы находитесь на странице вопроса "перевод из двоичной в десятичную систему счисления", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.