Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Почему в файлах нельзя вводить такие символы:<>?"* ?

5-9 класс

Шурончик 20 марта 2015 г., 10:22:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elena300682
20 марта 2015 г., 12:21:12 (9 лет назад)

Так как это системные знаки, и ввод таких знаков в имя файла создает ошибку в системе, т.к. комп считает это командой и пытается выполнить её

Ответить

Другие вопросы из категории

1.приведите пример информационной модели: а)ученика вашего класса б)игрока баскетбольной команды в)пациента ветеринарной лечебницы г)квартиры жилого дома

д)книга в библиотеке е)кассеты (диска) с звукозаписью(видеозаписью) ж)города 2.придумай пример информационной модели,образными элментами которой являются муляжи фруктов и цветов.

5. Какие устройства используются для вывода информации?

А) Принтер, процессор, колонки.
Б) Клавиатура, монитор, принтер.
В) Монитор, принтер, колонки.
Г) Монитор, процессор, принтер.

4. Что такое программное обеспечение компьютера?
А) Устройства для обработки информации.
Б) Совокупность всех устройств компьютера.
В) Устройства для ввода и вывода информации.

Читайте также

На планете Триа использую только числа от 1 до 27. Их записывают с помощью символов «<»,«.» и

«>». Запись числа N выполняется по следующему алгоритму:

1) весь интервал (1..27) делится на 3 равные части: от 1 до 9, от 10 до 18 и от 19 до 27.

2) если число N оказалось в первом интервале, записываем символ «<», если во втором­ символ «.», и если в третьем­ – символ «>»

3) делим оставшийся интервал (в который попало число N) на три части и определяем следующий знак кода, который записывается справа от предыдущих

4) повторяем шаги 2 и 3 до тех пор, пока оставшийся интервал не будет содержать одно число.

Например, число 22 будет закодировано как «>.<» (интервалы 19-27, 22-24, 22).

Определите, какое число записывается как «.<>»?

Имеется условный оператор:if D<>10 then writeln (‘ура!’) else writeln (‘плохо…’);Какими операторами его можно заменить?

Выберите несколько из 4 вариантов ответа:
1) if D=10 then writeln (‘ура!’) else writeln (‘плохо…’);
2) if not (D=10) then writeln (‘ура!’) else writeln (‘плохо…’);
3) if not (D<>10) then writeln (‘ура!’) else writeln (‘плохо…’);
4) if D=10 then writeln (‘плохо…’) else writeln (‘ура!’);

1....что такое файл?2......Имя файла(какие части,сколько символов можно брать,какие нельзя.)3.....Типы файлов и расширение.4.....Файловая систепа

определение.5.....Виды файловых систем.6....Путь к файлу на диске(определение примеря)7.....Полное имя файла (определение,с примером) Ответьте пожалуйста очень над*на 1,4,5 вопрос необязательно)

Одной из задач, возникающей при разработке поисковых систем, является поиск самых популярных сайтов по ключевым словам (тегам), описывающим сайт. Дан

список сайтов. Про каждый сайт известны набор тегов сайта и его популярность. Есть запрос в виде набора тегов. На запрос необходимо выдать самый популярный сайт, у которого в описании встречаются все теги из запроса.
Формат входного файла

В первой строке входного файла input.txt находится набор тегов, разделённых ровно одним пробелом, количество тегов не превосходит 5. Тегом назовём такую строку, которая содержит только строчные латинские буквы и ее длина не превосходит 10 символов. В следующей строке дано число N (1 ≤ N ≤ 20)— количество сайтов.

Каждый сайт описывается тремя строками. В первой строке название сайта. Название сайта состоит только из строчных латинских букв и точки. Длина названия сайта не превосходит 15 символов. Во второй строке набор тегов сайта, разделенных пробелами. Количество тегов не превосходит 10. В третьей строке число Ai(1 ≤ Ai ≤ 1000000)— популярность сайта.
Формат выходного файла

В выходной файл output.txt требуется вывести любой самый популярный сайт, у которых встречаются все теги из запроса. Гарантируется, что найдётся, хотя бы один сайт отвечающий запросу.
Пример входных и выходных данных

Input.txt
football volleyball
5
sportbox.ru
sport football volleyball basketball swimming hockey
5000
championat.com
sport football volleyball basketball hockey
4000
soccer.ru
sport football
6000
sport.ru
sport football vоlleyball
1000
sports.ru
sport football volleyball basketball swimming hockey
2000

Output.txt

sportbox.ru

Я задачу решила, на мои тесты работает.

Однако, когда я отправляю ее тестировать на сайт, вылезает что программа выдала неправильный ответ.

program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
s,r:string;
tegs,sait,d,x1:array[1..255] of string;
pop,l,x:array[1..100000] of integer;
i,j,k,n,f,max,max1:integer;
begin
assign(input,'Input.txt');reset(input);
assign(output,'Output.txt');rewrite(output);
readln(s);s:=s+' ';f:=0;
for i:= 1 to length(s) do begin
if s[i]<>' ' then r:=r+s[i];
if s[i]=' ' then begin k:=k+1;d[k]:=r;r:='';end;
end;
readln(n);
for i:= 1 to n do begin
readln(sait[i]);
readln(tegs[i]);
readln(pop[i]);
end;
for i:= 1 to n do begin
for j:= 1 to k do begin
if pos(d[j],tegs[i])<>0 then f:=f+1;
end;
l[i]:=f;
f:=0;
end;
max:=0;max1:=0;
f:=0;
for i:=1 to n do
if l[i]>max then max:=l[i];
for i:=1 to n do
if l[i]=max then begin inc(f);x[f]:=pop[i];x1[f]:=sait[i];end;
for i:=1 to f do
if x[i]>max1 then begin max:=x[i];k:=i;end;
writeln(x1[k]);
close(input);close(output);
end.

помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 – сложение, 2 – вычитание, 3 – умножение, 4 –

деление. Дан номер действия n и вещественные числа a, b (b<>0). Выполнить над числами указанное действие и вывести результат. Например, n=2, а=0,40, в=1,00. Результат: а-в=-0,60. Единицы длины пронумерованы так: 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр. Дан номер единицы длины и длина отрезка в этих единицах (вещественное число). Найти длину отрезка в метрах.



Вы находитесь на странице вопроса "Почему в файлах нельзя вводить такие символы:&lt;&gt;?"* ?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.