Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 975 ответов!

Подсчитать количество и сумму чисел кратных 3 в диапазоне от -30 до 30.

5-9 класс

Срочно!!!!В программе Pascal!!!

1980327 18 дек. 2016 г., 21:05:49 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asskill98
18 дек. 2016 г., 22:07:52 (7 лет назад)

var 
i,k,s : integer;
   begin
 k := 0; 
s := 0; 
for i := - 30 to 30 do   
if i mod 3 = 0 then   
begin 
  k := k +1;
    s := s + i;   
 end; 
writeln (k); 
writeln (s); 
end.

+ 0 -
Vebon
19 дек. 2016 г., 0:03:35 (7 лет назад)

program z;
var i,s,k:integer;
begin
s:=0;
k:=0;
for i:=-30 to 30 do
if i mod 3=0 then
begin
s:=s+i;
k:=k+1;
end;
write(s,' ',k);
end.
а тебе -30 и 30 включительно?

+ 0 -
Kimmariya2010
19 дек. 2016 г., 0:44:06 (7 лет назад)

А если подробно объяснить кто сможет,тот прям наилучшим будет(ответ того будет правильным)

Ответить

Другие вопросы из категории

1)Сколько бит информации содержит сообщение объемом 8 мегабайт ?

2)Сколько бит информации содержит сообщение 4 гигабайта?

1 килобайт =........ бит

1 мегабайт =...... бит
1 гигабайт = ..... бит
Я вас умоляю помогите. Я сейчас в школе и у меня по информатике идёт контрольная работу.

Читайте также

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 5.

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3.

(Pascal)

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 3. входные данные:3,12,25,9 выходные 21

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в

последовательности, а затем сами числа. В последовательности всегда имеется число кратное 6. Кол-во чисел не превышает 100. Введённые числа не привышают 300. Программа должна ввести одно число - сумму чисел кратных 6

1)В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2)В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.



Вы находитесь на странице вопроса "Подсчитать количество и сумму чисел кратных 3 в диапазоне от -30 до 30.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.