Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Двно целое число n.Составить программу нахождения количества цифр числа

10-11 класс

Ynaledomskaya 08 авг. 2014 г., 19:36:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Direkshioner1998
08 авг. 2014 г., 20:19:24 (9 лет назад)

var
  a:longint;
  s:string;
begin
  writeln('Введите целое положительное число');
  readln(a);
  Str(a,s);
  writeln('Количество цифр в числе равно ',length(s));
end.

Тестовый пример:

Введите целое положительное число
23434232
Количество цифр в числе равно 8


Ответить

Другие вопросы из категории

Задача в паскале.

Вывести на экран в порядке возрастания все цифры, не являющиеся цифрами данного десятичного натурального числа (переменной целого

Читайте также

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Составить программу в паскале по подсчету кол-ва претендентов, которые попадут в школьную баскетбольную команду,если рост игрока должен быть не менее

170 см. Считать число претендентов случайном числом в диапазоне от 150 до 200, число претендентов 50 (программу писать через массив)

У исполнителя Прибавитель 2 команды, которым присвоены номера: 1. Прибавить 1 2. Увеличить старшую цифру числа на 1. Первая из них увеличивает число на

экране на 1, а вторая увеличивает на один старшую цифру числа. Например число 23 с её помощью превращается в число 33. Если старшая цифра числа 9, то вторая команда оставляет это число неизменимым. Программа для Прибавителя это последовательность команд. Сколько есть программ , которые преобразуют число 35 в 37 ?



Вы находитесь на странице вопроса "Двно целое число n.Составить программу нахождения количества цифр числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.