Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Составить сумму вычисления : а)первых n натуральных чисел. б)первых n четных,первых n нечетных

5-9 класс

Korolek 29 окт. 2014 г., 7:38:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aljbina
29 окт. 2014 г., 9:50:49 (9 лет назад)

а) 

var i,n,s: integer;
begin
readln(n);
s:=0;
for i:=1 to n do begin
s:=s+i;
end;
writeln(s);
end.

б)

var a,n,i,s: integer;
begin
readln(n);
s:=0;
a:=2;
for i:=1 to n do begin
s:=s+a;
a:=a+2
end;
writeln('Сумма первых ',n,' четных чисел равна ',s);
a:=1;
s:=0;
for i:=1 to n do begin
s:=s+a;
a:=a+2;
end;
writeln('Сумма первых ',n,' нечетных чисел равна ',s);
end.

 

Ответить

Другие вопросы из категории

каждый ученик в классе изучает либо английский язык, либо французкий, либо оба этих языка. Английский изучают 25 человек, французкий- 27, а тот и другой

изучают 18 человек. Сколько всего учеников в классе? Решите задачу с помощью кругов Эйлера

Необходимо оформить несколько документов. Запишите, какие возможности текстовых процессоров вы будете использовать в каждом из них (маркированный

список, нумерованный список, таблица, многоуровневый нумерованный список, многоуровневый маркированный список): а) расписание уроков на неделю для восьмых классов; б) список учителей школы с указанием предметов, которые они ведут; в) список учеников 8Б класса; г) список покупок в магазине;, д) список неуспевающих студентов с указанием предметов, по которым у них имеются долги.

Читайте также

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

Составьте алгоритм вычисления суммы всех

натуральных чисел, не превышающих заданного натурального числа N.
Проверьте алгоритм трассировкой. Напишите программу на Паскале.



Вы находитесь на странице вопроса "Составить сумму вычисления : а)первых n натуральных чисел. б)первых n четных,первых n нечетных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.