Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 971 ответов!

Задача 35. Решить Паскалем.

5-9 класс

Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и выписанной окружностей.

1l0vey0u 15 сент. 2014 г., 20:32:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vova38
15 сент. 2014 г., 21:17:02 (9 лет назад)

const s3 = sqrt(3);
var a: real;
begin
  write('сторона: ');
  readln(a);
  writeln('площадь: ', a*a*s3/4);
  writeln('высота: ', a*s3/2);
  writeln('радиус описанной окр.: ', a*s3/3);
  writeln('радиус вписанной окр.: ', a*s3/6);
end.

Ответить

Другие вопросы из категории

1)составить программу, которая подсчитает объем любого шара по формуле: V=4/3Пr^3 2)даны действительные числа x и y. необходимо определить

принадлежит ли точка с координатами (x,y) окружности с радиусом R и центром в точке (x1,y1).

3)дан одномерный числовой массиф В(16). Необходимо вывести на экран индексы элементов значения, которых равны числу P.

cрочно надо на языке паскаль составить плиз)

десятичная дробь в PoscalABC
СТОРОНА ПЕРЕДАЮЩАЯ ИНФОРМАЦИЮ
Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения

увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.

Читайте также

Решить задачи с помощью Паскаля:

1. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
2. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую- по убыванию. Здесь решать лучше методом выбора.

Помогите, пожалуйста, с задачами в программе "Паскаль"! ОЧЕНЬ НАДООООО!!!!

Задание во вложении, необходимо решить задачи с 3 по 5

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

РЕШИТЬ ЗАДАЧУ НА ТУРБО ПАСКАЛЕ

ЖЕЛАТЕЛЬНО С ИСПОЛЬЗОВАНИЕМ СТРУКТУРЫ CASE OF

Пусть элементом круга является радиус(первый элемент),диаметр (второй элемент) и длина окружности( третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.



Вы находитесь на странице вопроса "Задача 35. Решить Паскалем.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.