Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите с Паскалем)Дан массив В[10], вводится с клавиатуры. Найти произведение нечетных и количество положительных

10-11 класс

Karinochka806 22 дек. 2016 г., 23:03:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastia467
23 дек. 2016 г., 0:06:16 (7 лет назад)

const
  n = 10;

var
  b: array[1..n] of integer;
  i, kp: integer;
  pn: longint;

begin
  Writeln('Введите ', n, ' элементов массива');
  kp := 0; pn := 1;
  for i := 1 to n do
  begin
    Read(b[i]);
    if b[i] > 0 then kp := kp + 1;
    if (b[i] mod 2 <> 0) then pn := pn * b[i]
  end;
  Writeln;
  Writeln('Количество положительных элементов массива равно ', kp);
  Writeln('Произведение нечетных элементов массива равно ', pn)
end.

Тестовое решение.
Введите 10 элементов массива
5 7 12 8 3 5 11 4 -4 7

Количество положительных элементов массива равно 9
Произведение нечетных элементов массива равно 40425


Ответить

Другие вопросы из категории

Решить задачу в Паскале (абв - всё в одной программе)

"В числовом массиве из 10 элементов, заданных с клавиатуры:
а) найти сумму положительных эелементов, стоящих на чётных местах;
б) найти произведение элементов массива, кратных 3 и стоящих на нечётных местах;
в) найти кол-во двузначных чисел в массиве."
СРОЧНО!!! Жду верного решения :) спасибо заранее

При поступлении в вуз абитуриенты, получившие "двойку" на первом экзамене, ко второму не допускаются. В массиве A[n] записаны оценки экзаменую

щихся, полученные на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену.

Читайте также

Помогите пожалуйста, очень срочно!

Дан массив А , содержащий N элементов .Найти произведение отрицательных элементов массива и их количество. Нарисовать блок-схему. Просчитать значения: N=10 , массив А={-2;0;10;-1;7;3;0}

Помогите пожалуйста решить задачки в паскале.

1.В одномерном массиве перенести элемент, стоящий на первом месте в конец массива.
2.вывести на печать номера точек, лежащих в круге радиусом r. Координаты точек заданы массивами (x1,x2,...,x10), (y1,y2,...,y10).
3.В одномерном массиве найти сумму положительных, произведение отрицательных, количество четных элементов.
4.Дан массив, состоящий из 50 элементов, найти предпоследний нечетнный элемент.

1) Вводится 4 числа. Вывести на экран наибольшую из первых цифр заданных чисел. Например, если a=46, b=831, c=2996, d=486, то напечатать число 8.

Использовать процедуру. - Написать на Паскале.

2) Дан массив A(10,5). Поменять местами элементы первого столбца с элементами столбца, в котором находится максимальный элемент массива. - Написать на Паскале.

3) Вводятся значения трех переменных. Переставить значения. Дополнительные переменные не использовать.
Составить алгоритм.

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.



Вы находитесь на странице вопроса "Помогите с Паскалем)Дан массив В[10], вводится с клавиатуры. Найти произведение нечетных и количество положительных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.