Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите пожалуйста! Нужно составить программу на языке паскаль для решения такой задачи : поиск двух учащихся школы,у которых совпадает имя?

10-11 класс

Mashkak81 30 нояб. 2014 г., 8:06:50 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
23293015
30 нояб. 2014 г., 10:41:42 (9 лет назад)

Вы не указали как хранятся данные о студентах и как осуществляется ввод. Попробуйте так, хотя я уже давно в Паскале не писала.

 

program pr1;

procedure CreateMass(var str:mass; n:integer);
var i:integer;
begin
  for i:=1 to n do begin
  write('Введите имя учащегося: ');
  readln(str[i])
  end
end;

procedure SearchN (str:mass; n:integer);
var i, j, s1, s2:integer;
    b:boolean;
begin
  b:=false;
  j:=1;
  while (j <= (n-1)) and (not b) do
  begin
    for i:=j+1 to n do
    begin
      if str[j]=str[i] then
      begin
        b:=true;
        s1:=i;
        s2:=j
      end
    end;
    j:=j+1
  end;
  if (not b) then writeln('Нет двух студентов с одинаковыми именами.') else
  writeln('Студенты с одинаковыми именами - ',str[s1], ' находятся в массиве под номерами ', s1, ' и ', s2, '.')
end;

type mass = array [1..n] of string;
const n = 10;
var str:mass;
begin
  CreateMass(str, n);
  SearchN(str, n)
end.

Ответить

Другие вопросы из категории

Читалкин подошел книжному шкафу с восемью учебниками по разным

предметам. Сколько битов информации содержит сообщение о том, что наугад
выбранная Читалкиным книга оказалась учебником информатики?
А) 5 Б) 2 В) 3 Г) 4

Автомат получает на вход четырёхзначное восьмеричное число. По этому

числу строится новое число по следующим правилам.
1. Складываются первая и вторая, а также третья и четвертая цифры.
2. Полученные два восьмеричных числа записываются друг за другом в
порядке возрастания (без разделителей); основание системы счисления не
пишется.
Пример. Исходное число: 6331. Суммы: 6+3 = 11; 3+1 = 4. Результат: 411.
Определите, какое из следующих чисел может быть результатом работы
автомата.
1) 812 2) 617 3) 1512 4) 1213

напишите программу ,которая

запрашивает значения четырех переменных (A,B,C,D) типа integer и выводит их сумму. ввод первой пары значений (A,B) произведите на одной строке ,ввод другой пары. (C,D) ; на другой строке. Результат выведите на отдельную строку и курсор оставьте на той же строке. Эту рограмму надо написать на языке pascal

Помогите, пожалуйста, программисты. Basic Составьте подпрограмму, изменяющую одномерный массив чисел делением его

положительных элементов на свои индексы и определяющую число измененных
элементов. Используя эту процедуру, определите, в каком из двух заданных
одномерных массивов А или В больше измененных элементов, а также выведите
измененные массивы А и В. Если же число измененных элементов одинаково, то
выведите соответствующее сообщение

Написать программу в VBA (visual basic)

1. Вывести на экран в строку все числа двадцати, делящиеся на три.


2. Вычислить S=2n+n!
спасибо большое за ранее)))))но нужно очень срочно!!

Читайте также

Напишите программу на языке Паскаль, для решения следующей задачи:

Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры).
(Подсказка. Используйте тип данных integer и операции div и mod)

Составить программу на языке Паскаль.Определите, кратно ли трем значение целочисленной переменной X. Если это имеет место, то выведите на печать

значение Х с соответствующим сообщением, если нет, то выведите на печать "нет".
Помогите, пожалуйста, очень нужно)

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Напишите программу на языке паскадь для решения следущей задачи.

Известна площадь квадрата. Найдите периметр и диагональ квадрата



Вы находитесь на странице вопроса "Помогите пожалуйста! Нужно составить программу на языке паскаль для решения такой задачи : поиск двух учащихся школы,у которых совпадает имя?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.