Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1.Заменить все положительные элементы массива на 99.

10-11 класс

2.Составить программу, вычисл. произведения положительных и сумму отрицательных элементов.

людовик14 29 апр. 2015 г., 6:12:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jennja73
29 апр. 2015 г., 8:55:35 (9 лет назад)

Pascal:
1)
const n = 10;
var a:array [1..n] of integer;
     i:integer;
begin
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    write (a[i]:3);
   end;
  writeln;
  for i:=1 to n do
   begin
    if a[i]>0 then a[i]:=99;
    write (a[i]:3);
   end;
  writeln;
end.

2)
const n = 10;
var a:array [1..n] of integer;
     p,s,i:longint;
begin
  p:=1;
  s:=0;
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    if a[i]>0 then p:=p*a[i] else
     if a[i]<0 then s:=s+a[i];
    write(a[i]:3);
   end;
  writeln;
  writeln ('Proizvedenie: ',p);
  writeln ('Summa: ',s);
end.

C++:
1)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      a[i] = 99;
  }
  cout <<endl;
  for (int i = 0; i<10; i++)
    cout <<a[i] <<" ";
  cout <<endl;
  return 0;
}

2)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  int p = 1,s = 0;
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      p*=a[i];
    else if (a[i]<0) s+=a[i];
  }
  cout <<endl;
  cout <<"Summa: " <<s <<endl
         <<"Proizvedenie: " <<p <<endl;
  return 0;
}

Ответить

Читайте также

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835

Cрочно! Язык visual basic,массивы - задачи:

1)Заменить значение любого элемента массива на а
2)Определить имеются ли четные числа в массиве
3)Заменить все элементы некоторой строки на заданное число
4)Вывести все элементы N столбца и M строки

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.



Вы находитесь на странице вопроса "1.Заменить все положительные элементы массива на 99.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.