Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 971 ответов!

Даны 3 числа: a,b,c. Определить среднее арифметическое двух не максимальных чисел. Позязя^^

5-9 класс

KarinaFelton 15 сент. 2016 г., 14:00:53 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Njemin
15 сент. 2016 г., 15:35:22 (7 лет назад)

var
a,b,c:integer;
s:real;
begin
read(a,b,c);
if (a>b)and (a>c) then
 s:=(b+c)/2else
if (c>a)and (c>b) then
s:=(b+a)/2
else
if (b>a)and (b>c) then
 s:=(a+c)/2;
writeln(s);
end.

+ 0 -
MIster007007
15 сент. 2016 г., 16:32:53 (7 лет назад)

Написать программу?

Ответить

Другие вопросы из категории

написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 5.5 , вычисления значения

величины Z=X-Y и вывода значения величины Z. Протестировать алгоритм для X=5.5, X=0, X=-10.2

Написать программу на языке Паскаль.

Известна сторона квадрата А и радиус круга R.Какая из фигур имеет большую площадь?

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

исло M называется средним арифметическим двух чисел A и B, если M равно (A + B) / 2. Васе на день рождения подарили два числа A и B. Именинник легко

вычислил их среднее арифметическое и так обрадовался, что потерял число B. Помогите Васе восстановить потерянное число.

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

1 задача.Вычислить произведение квадратов n первых натуральных чисел.Для любого n введенного с клвитуры.2 Найти первое чётное натуральное числоЮ куб

которого больше числа x,введенного с клавитуры. 3.Даны вещественные числа b1,b2,...... b10.(ввести с клавитуры).Определите среднее арифметическое тех из них,которые кратны числу n, введенному с клавитуры.

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.



Вы находитесь на странице вопроса "Даны 3 числа: a,b,c. Определить среднее арифметическое двух не максимальных чисел. Позязя^^", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.