Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

С клавиатуры вводятся два натуральных числа N и K (0<N<=K<=200000). Требуется написать программу, которая находит сумму простых чисел,

5-9 класс

расположенных между N и K(включая эти числа).
Пример входных данных: 2 5
Пример выходных данных: 10

Pavel155487 16 дек. 2013 г., 1:53:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Марфуха
16 дек. 2013 г., 2:24:35 (10 лет назад)

var
  simple: array[1..10000] of integer;
  i, j, a, b, simple_n, s: integer;
  is_simple: boolean;

begin
  read(a, b);
 
  for i := 2 to b do begin
    is_simple := true;
    for j := 1 to simple_n do
      is_simple := is_simple and (i mod simple[j] <> 0);
    if is_simple then begin
      simple_n := simple_n + 1;
      simple[simple_n] := i;
      writeln(i);
      if i >= a then s := s + i;
    end;
  end;
 
  writeln(s);
end.

Ответить

Другие вопросы из категории

напишите программу которая в последовательности натуральных чисел определяет минимальное число кратное 3. знаю как написать программу

для максимального числа

var

a:integer;

b:longint;

begin

b:=0;

readln(a);

while (a<>0) do

begin

if ((a mod 3=0) and (a>b)) then

b:=a;

readln(a);

end;

writeln(b);

readln

end.

как для минимального??

В одном множестве 40 элементов , а в другом - 30. какое максимальное количество злементов может быть в их пересечении - множестве, которому принадлежат те

и только те элементы, которые одновременно принадлежат всем исходным множествам

Читайте также

В ПАСКАЛЕ!№1 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить сколько среди них чисел, кратных 4; №2 С клавиатуры вводятся 10

натуральных двузначных чисел. Определить

среднее арифметическое нечетных чисел;

№3 С клавиатуры вводятся 10 натуральных двузначных чисел. Определить

верно ли, что среди введенных чисел есть число, в котором первая цифра в два раза больше последней.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

Петя Васечкин хочет выяснить, делится ли на 7 натуральное число, состоящее не более чем

из 60 цифр.
Требуется написать программу, которая выполняет желание Пети и находит остаток от
деления введенного числа на 7



Вы находитесь на странице вопроса "С клавиатуры вводятся два натуральных числа N и K (0&lt;N&lt;=K&lt;=200000). Требуется написать программу, которая находит сумму простых чисел,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.