Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Написать программу в АБС паскале: написать программу и процедуру перевода из десятичной системы в 8-ичную.

5-9 класс

6ukaIIIka 05 окт. 2013 г., 12:56:51 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NATASHA21619
05 окт. 2013 г., 15:34:23 (10 лет назад)

Program Perevod; 

Uses crt;
var z:integer;

 

procedure ToOct(z:integer);
begin
  if (z>1) then ToOct(z div 8);
  write(z mod 8:1);
end;


begin
     clrscr;
      write('Введите число:');
      readln(z);
      writeln('В Десятичной:',z:6);
      write('В восьмеричной: ');
      ToOct(z);
       readkey;
end.

 

 

 

Ответить

Другие вопросы из категории

может кто помочь перевести?
помогите!!!!!!8) Сколько байт содержится в 40 мегабайтах?9) Сколько десятизначных паролей можно составить, пользуясь цифровой клавиатурой? Сколько

времени потребуется на расшифровку такого пароля, используя компьютер, производящий
1000000000 операций в секунду?

10) Видеорегистратор нарушений на дорогах записывает номера машин, состоящие из двух букв и
трех цифр. Какой объем информации, записанной регистратором, если он записал номера 1000
машин?

1.Стремясь усилить воздействие на все органы чувств человека во время просмотров кинофильмов,люди придумали 3D , 4D...и даже 7D кинотеатры.Какая

информация не воспринимается человеком при данных просмотрах?
а)тактильная б)вкусовая в)обонятельная г)слуховая
2.У Яши флешка объемом 8Гб,у Алины в два раза больше ,чем у Яши,а у Марата флешка составляет четыре третьих общего объема флешек у Алины и Яши.Какой объем флешки у Марата?

Читайте также

№1 Семенова Анастасия 1. Закодировать свои имя и фамилию следующим образом: А = 1, Б = 2, В = 3, ….. , Ю = 32, Я = 33.

2. Найти сумму ГЛАСНЫХ букв своей фамилии.
3. Найти сумму СОГЛАСНЫХ букв своего имени.
4. Перевести сумму букв фамилии ИЗ ДЕСЯТИЧНОЙ СС В ДЕВЯТИРИЧНУЮ СС
5. Перевести сумму букв имени ИЗ ДЕСЯТИЧНОЙ СС В ДВЕНАДЦАТИРИЧНУЮ СС.

6. Найти сумму букв своей фамилии по алгоритму от 22.04.2013г.
7. Возвести в степень 3/2 полученное число.
8. Целую часть полученного десятичного числа перевести последовательно в 2-ную, 3-ную, 7-ную, 12-ную и 16-ную системы счисления.
9. Сделать вывод на основе полученых результатов.

№2На языке программирования Паскаль составить программу перевода из десятичной системы счисления в систему счисления с основанием Х,
где Х - целое число, определяемое по такому правилу:
если 2-я буква фамилии учащегося находится в интервале от А до Д, то Х = 9;
если 2-я буква фамилии учащегося находится в интервале от Е до К, то Х = 8;
если 2-я буква фамилии учащегося находится в интервале от Л до Р, то Х = 7;
если 2-я буква фамилии учащегося находится в интервале от С до Ц, то Х = 6;
если 2-я буква фамилии учащегося находится в интервале от Ч до Я, то Х = 5.

перевод из двоичной в десятичную систему счисления

101010
110111
перевод из восмеричной в десятичную систему счисления

703

101

перевод из десятичной в двоичную систему счисления

535

111

Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)



Вы находитесь на странице вопроса "Написать программу в АБС паскале: написать программу и процедуру перевода из десятичной системы в 8-ичную.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.