Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

подсчитайте сумму элементов каждой строки массива целых чисел X[1:3,1:2](составить алгоритм и блок-схему)

10-11 класс

василиса1996 29 апр. 2014 г., 1:34:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aminamaryam10
29 апр. 2014 г., 3:14:10 (9 лет назад)

var a: array [1..100,1..100] of integer;
n,m,s,i,j:integer;
Begin
    read(n,m);
    for i:= 1 to n do
        for j:= 1 to m do
            read(a[i,j]);

    for i:= 1 to n do begin
        s:=0;
        for j:= 1 to m do
            s:=s+a[i,j];
        writeln('S[',i,'] = ',s);
    end;
End.

Ответить

Другие вопросы из категории

Помогите пожалуйста!!! Кто чем может :)

При проектировании БД были определены следующие отношения: МАГАЗИН (Номер_магазина, Тип, Адрес, Директор, Телефон) ; ОТДЕЛ (Название_отд, Заведующий, Телефон) ; ПРОДАВЕЦ (Табельный_ном. , Фамилия, Имя, Отчество, Категория) Являются ли эти отношения связанными? Добавьте всё, что необходимо для их связи; изобразите схему БД в графическом виде.

1)Сколько бит необходимо для записи выражения ПРОБЕЛ - это тоже символ.(ход решения)

2)Получить шестнадцатеричную форму внутреннего представления целого числа в 2-х
байтовой ячейке.(ход решения)
а) 1305
б) -1305

3) Чёрно-белая фотография разбита на точки,каждая из которых кодируется пятью битами информации,каков информационный объём фотографии 10х15 см,если 1 квадратный сантиметр содержит 1600 точек? (ход решения)



Читайте также

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы

Решать задачу нужно на древнем ТП7 (Турбо паскаль).

Вычислить сумму элементов каждой строки, вводимого С КЛАВИАТУРЫ ДВУМЕРНОГО массива. Обязательно с клавиатуры. Напишите программу пожалуйста.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.



Вы находитесь на странице вопроса "подсчитайте сумму элементов каждой строки массива целых чисел X[1:3,1:2](составить алгоритм и блок-схему)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.